image.mk: fix initramfs kernel build instructions leaking across device sections
authorFelix Fietkau <nbd@openwrt.org>
Mon, 30 Mar 2015 13:03:58 +0000 (13:03 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 30 Mar 2015 13:03:58 +0000 (13:03 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45156

include/image.mk

index 0d388ec6667dc11288e51ba27375a8e88748e980..08b516d854b5fa7f57f06c023d6bdfd9b6a19d97 100644 (file)
@@ -353,7 +353,7 @@ define Device/ExportVar
   $(1) : $(2):=$$($(2))
 
 endef
-Device/Export = $(foreach var,$(DEVICE_VARS) KERNEL,$(call Device/ExportVar,$(1),$(var)))
+Device/Export = $(foreach var,$(DEVICE_VARS) KERNEL KERNEL_INITRAMFS,$(call Device/ExportVar,$(1),$(var)))
 
 define Device/Check
   _TARGET = $$(if $$(filter $(PROFILE),$$(PROFILES)),install,install-disabled)