build: prereq: drop support for Python 3.5
authorAndre Heider <a.heider@gmail.com>
Tue, 16 Feb 2021 07:21:08 +0000 (08:21 +0100)
committerPetr Štetiar <ynezz@true.cz>
Mon, 15 Mar 2021 13:00:44 +0000 (14:00 +0100)
The final Python 3.5 release was 3.5.10 in September 2020 [0].
This release series is now End-of-Life (EOL).

The only LTS distribution that still only ships Python 3.5 is Ubuntu 16.04,
which will be EOL in April 2021 [1].

The meson build system bumped their python requirement to 3.6 for the 0.57.0
release. This patch ensures that OpenWrt can update meson while still
relying on the host python.

[0] https://www.python.org/dev/peps/pep-0478/#id4
[1] https://ubuntu.com/about/release-cycle
[2] https://mesonbuild.com/Release-notes-for-0-57-0.html#minimum-required-python-version-updated-to-36

Signed-off-by: Andre Heider <a.heider@gmail.com>
[python3.6+ in README.md]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
README.md
include/prereq-build.mk

index 68063d9f86678a4aaabea3786e355b87982dd683..0581a94a096d738fce93fe639070ffed9fb76ddb 100644 (file)
--- a/README.md
+++ b/README.md
@@ -25,7 +25,7 @@ the [Build System Setup](https://openwrt.org/docs/guide-developer/build-system/i
 documentation.
 
 ```
-gcc-6+ binutils bzip2 flex python3 perl make4.1+ find grep diff unzip gawk getopt
+gcc-6+ binutils bzip2 flex python3.6+ perl make4.1+ find grep diff unzip gawk getopt
 subversion libz-dev libc-dev rsync which
 ```
 
index 32edc6e4370aa4197c1df0cb76f867a104469534..b2526a1ec10cab8a76263cbf0728a121fff86174 100644 (file)
@@ -141,21 +141,19 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
 
 $(eval $(call CleanupPython2))
 
-$(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+$(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
        python3.9 -V 2>&1 | grep 'Python 3', \
        python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \
-       python3.5 -V 2>&1 | grep 'Python 3', \
-       python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+       python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
 
-$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+$(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
        python3.9 -V 2>&1 | grep 'Python 3', \
        python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \
-       python3.5 -V 2>&1 | grep 'Python 3', \
-       python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+       python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
        git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))