base-files: release an attached loop device on umounting
authorFlorian Fainelli <florian@openwrt.org>
Wed, 19 Sep 2012 15:13:44 +0000 (15:13 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 19 Sep 2012 15:13:44 +0000 (15:13 +0000)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 33477

package/base-files/Makefile
package/base-files/files/etc/init.d/umount

index 13927528c0e5a093ea4b4288f08414c20315ffd4..1d56e9fc784fb71e4373c62f3ec14e0d21d6c92f 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=116
+PKG_RELEASE:=117
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index a4e477e2e9b7f8bdaf9383e6eb82e3e7aabb9215..5a750b93c6602b3608039cf0db3cbca3acfa711a 100755 (executable)
@@ -4,5 +4,5 @@
 STOP=99
 stop() {
        sync
-       umount -a -r
+       umount -a -d -r
 }