tools/meson: fix usage with SDK
authorRosen Penev <rosenp@gmail.com>
Sat, 9 Oct 2021 19:24:44 +0000 (12:24 -0700)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 10 Oct 2021 18:39:32 +0000 (19:39 +0100)
The python path cannot be embedded in the meson binary as it changes
with the SDK.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
include/meson.mk
tools/meson/Makefile

index 9862f0e662b74b5b88440c7aa061363e5848b2f4..12e38b9e71e0f67aca467b8c577c1432d7e05a46 100644 (file)
@@ -56,7 +56,7 @@ MESON_CPU:="$(CPU_TYPE)$(if $(CPU_SUBTYPE),+$(CPU_SUBTYPE))"
 endif
 
 define Meson
-       $(2) $(STAGING_DIR_HOST)/bin/meson $(1)
+       $(2) $(STAGING_DIR_HOST)/bin/$(PYTHON) $(STAGING_DIR_HOST)/bin/meson $(1)
 endef
 
 define Meson/CreateNativeFile
index 0cf0efba4726689726c69085be569e70b9163b30..1aab5d8fcb1e0dd99aa527ef758bd884250f74bb 100644 (file)
@@ -21,7 +21,7 @@ endef
 
 define Host/Install
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
-       $(HOST_BUILD_DIR)/packaging/create_zipapp.py $(HOST_BUILD_DIR) --interpreter $(STAGING_DIR_HOST)/bin/$(PYTHON) --outfile $(STAGING_DIR_HOST)/bin/meson
+       $(HOST_BUILD_DIR)/packaging/create_zipapp.py $(HOST_BUILD_DIR) --outfile $(STAGING_DIR_HOST)/bin/meson
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/lib/meson
        $(INSTALL_CONF) files/openwrt-cross.txt.in $(STAGING_DIR_HOST)/lib/meson/
        $(INSTALL_CONF) files/openwrt-native.txt.in $(STAGING_DIR_HOST)/lib/meson/