openssl: detect configuration changes and clean build tree accordingly (fixes #15067)
authorFelix Fietkau <nbd@openwrt.org>
Sun, 9 Mar 2014 13:19:29 +0000 (13:19 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 9 Mar 2014 13:19:29 +0000 (13:19 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 39852

package/libs/openssl/Makefile

index fe99a534b84d98bd1f8e582150879856c33c6675..38679acb2be9a15337836e06e4a97cc74f39cb22 100644 (file)
@@ -110,7 +110,13 @@ else
   endif
 endif
 
   endif
 endif
 
+STAMP_CONFIGURED := $(STAMP_CONFIGURED)_$(subst $(space),_,$(OPENSSL_OPTIONS))
+
 define Build/Configure
 define Build/Configure
+       [ -f $(STAMP_CONFIGURED) ] || { \
+               rm -f $(PKG_BUILD_DIR)/*.so.* $(PKG_BUILD_DIR)/*.a; \
+               find $(PKG_BUILD_DIR) -name \*.o | xargs rm -f; \
+       }
        (cd $(PKG_BUILD_DIR); \
                ./Configure $(OPENSSL_TARGET) \
                        --prefix=/usr \
        (cd $(PKG_BUILD_DIR); \
                ./Configure $(OPENSSL_TARGET) \
                        --prefix=/usr \