build: fix HOST_CONFIGURE_VARS placement
authorJo-Philipp Wich <jo@mein.io>
Thu, 5 Jan 2017 14:51:05 +0000 (15:51 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 10 Jan 2017 11:28:32 +0000 (12:28 +0100)
Instead of passing HOST_CONFIGURE_VARS as arguments to the configure script,
pass it as environment variables which brings the logic in line with the
behaviour of package-defaults.mk.

The change is needed since passing environment variables as configure
parameters only works with GNU autoconf which evaluates command line arguments
looking like variable assignments. Doing the same with non-autoconf configure
scripts is not guaranteed to work since such scripts might terminate due to
unknown argument errors.

One example case is the cmake configure script which bails out when called
as "./configure LDFLAGS=..." but not when called as "LDFLAGS=... ./configure".

Also change the SHELL override to CONFIG_SHELL in the default
HOST_CONFIGURE_VARS as the former is not properly propagated through the
various GNU configure invocations since it gets lost when configure re-
executes itself.

A prior attempt to change the variable placement had to be reverted due to
the missing SHELL -> CONFIG_SHELL change, leading to misgenerated libtool
executables in various packages.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/host-build.mk

index 4b4ffe4c9dd258b301b04bb9d02abfe05208cdbe..5cfbdeba5138c4362f82b7ae86b910a1f41f082a 100644 (file)
@@ -53,7 +53,7 @@ HOST_CONFIGURE_VARS = \
        CFLAGS="$(HOST_CFLAGS)" \
        CPPFLAGS="$(HOST_CPPFLAGS)" \
        LDFLAGS="$(HOST_LDFLAGS)" \
-       SHELL="$(SHELL)"
+       CONFIG_SHELL="$(SHELL)"
 
 HOST_CONFIGURE_ARGS = \
        --target=$(GNU_HOST_NAME) \
@@ -75,9 +75,9 @@ define Host/Configure/Default
        $(if $(HOST_CONFIGURE_PARALLEL),+)(cd $(HOST_BUILD_DIR)/$(3); \
                if [ -x configure ]; then \
                        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
+                       $(HOST_CONFIGURE_VARS) \
                        $(2) \
                        $(HOST_CONFIGURE_CMD) \
-                       $(HOST_CONFIGURE_VARS) \
                        $(HOST_CONFIGURE_ARGS) \
                        $(1); \
                fi \