don't copy initramfs.elf unconditionally
authorImre Kaloz <kaloz@openwrt.org>
Fri, 26 Dec 2014 14:31:45 +0000 (14:31 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 26 Dec 2014 14:31:45 +0000 (14:31 +0000)
targets that need it should do it in their image Makefile

Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 43780

include/image.mk

index f9b8998ed4bae6729c7732521735f1bda1b44731..d6c8b7af87a3ca0a19b30e0c36878c0aca3320c5 100644 (file)
@@ -89,7 +89,6 @@ define prepare_generic_squashfs
 endef
 
 define Image/BuildKernel/Initramfs
-       cp $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.elf
        $(call Image/Build/Initramfs)
 endef