kernel: remove an old kernel compatibility line from module packaging
authorFelix Fietkau <nbd@nbd.name>
Thu, 22 Feb 2018 11:16:19 +0000 (12:16 +0100)
committerFelix Fietkau <nbd@nbd.name>
Sun, 4 Mar 2018 18:37:22 +0000 (19:37 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/linux/modules/i2c.mk

index 2975db5dc22f6ae6231ea9f0aacbc3ba0b9c7217..4cf37dae077b6a8147edda2cabc9e4d1a973f18a 100644 (file)
@@ -24,10 +24,6 @@ I2C_CORE_MODULES:= \
   CONFIG_I2C:drivers/i2c/i2c-core \
   CONFIG_I2C_CHARDEV:drivers/i2c/i2c-dev
 
-ifeq ($(CONFIG_OF),y)
-  I2C_CORE_MODULES+=CONFIG_OF_I2C:drivers/of/of_i2c@lt3.12
-endif
-
 define KernelPackage/i2c-core
   $(call i2c_defaults,$(I2C_CORE_MODULES),51)
   TITLE:=I2C support