lantiq: add Amazon-SE subtarget
authorTino Reichardt <milky-lede@mcmilk.de>
Sun, 26 Feb 2017 20:26:08 +0000 (21:26 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 3 Jun 2017 19:14:07 +0000 (21:14 +0200)
Re-Add support for the Amazon-SE subtarget on Lantiq.

Signed-off-by: Tino Reichardt <milky-lede@mcmilk.de>
target/linux/lantiq/Makefile
target/linux/lantiq/ase/config-default [new file with mode: 0644]
target/linux/lantiq/ase/profiles/00-default.mk [new file with mode: 0644]
target/linux/lantiq/ase/target.mk [new file with mode: 0644]

index 3e4f48e7b12377c67c931ad3b2b81fe65541ee61..a92e181bcf8da9703ae1d9452f11f1dc78c2c1da 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 BOARD:=lantiq
 BOARDNAME:=Lantiq
 FEATURES:=squashfs
-SUBTARGETS:=xrx200 xway xway_legacy falcon
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
 MAINTAINER:=John Crispin <john@phrozen.org>
 
 KERNEL_PATCHVER:=4.4
diff --git a/target/linux/lantiq/ase/config-default b/target/linux/lantiq/ase/config-default
new file mode 100644 (file)
index 0000000..b6cd4f3
--- /dev/null
@@ -0,0 +1,26 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
+CONFIG_CPU_MIPS32_R1=y
+# CONFIG_CPU_MIPS32_R2 is not set
+CONFIG_CPU_MIPSR1=y
+CONFIG_CRC16=y
+CONFIG_CRYPTO_DEFLATE=y
+CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_FIRMWARE_MEMMAP=y
+CONFIG_GPIO_GENERIC=y
+CONFIG_GPIO_GENERIC_PLATFORM=y
+CONFIG_HAVE_IRQ_EXIT_ON_IRQ_STACK=y
+# CONFIG_ISDN is not set
+# CONFIG_LBDAF is not set
+CONFIG_LEDS_TRIGGER_HEARTBEAT=y
+CONFIG_MIPS_FPU_EMULATOR=y
+# CONFIG_PSB6970_PHY is not set
+# CONFIG_RTL8366_SMI is not set
+CONFIG_SOC_AMAZON_SE=y
+# CONFIG_SOC_XWAY is not set
+# CONFIG_SPI is not set
+CONFIG_USB_SUPPORT=y
+# CONFIG_WIRELESS is not set
+# CONFIG_WLAN is not set
+CONFIG_ZLIB_DEFLATE=y
+CONFIG_ZLIB_INFLATE=y
diff --git a/target/linux/lantiq/ase/profiles/00-default.mk b/target/linux/lantiq/ase/profiles/00-default.mk
new file mode 100644 (file)
index 0000000..26bc8b5
--- /dev/null
@@ -0,0 +1,9 @@
+define Profile/Default
+       NAME:=Default Profile
+       PRIORITY:=1
+endef
+
+define Profile/Default/Description
+       Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/lantiq/ase/target.mk b/target/linux/lantiq/ase/target.mk
new file mode 100644 (file)
index 0000000..5f6c03b
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2016 LEDE Project
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+ARCH:=mips
+SUBTARGET:=ase
+BOARDNAME:=Amazon-SE
+FEATURES:=squashfs atm mips16 small_flash
+CPU_TYPE:=mips32
+
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug \
+       kmod-ltq-adsl-ase kmod-ltq-adsl-ase-mei \
+       kmod-ltq-adsl-ase-fw-b kmod-ltq-atm-ase \
+       ltq-adsl-app ppp-mod-pppoe
+
+define Target/Description
+       Lantiq Amazon-SE Boards
+endef