uci: implement a uci_toogle_state() wrapper in the shell api which calls uci_revert_s...
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 15 Jul 2011 14:52:38 +0000 (14:52 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 15 Jul 2011 14:52:38 +0000 (14:52 +0000)
SVN-Revision: 27614

package/uci/Makefile
package/uci/files/lib/config/uci.sh

index 5a9b85500200adddfff436985d2ce1f968e48019..08b38f916fe17e85725613d3e4b99031b6da0b81 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,7 +12,7 @@ UCI_RELEASE=2
 
 PKG_NAME:=uci
 PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_REV:=5b6e96336d6a615a72c274cceaea8c2fe74d7642
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index 8dcb92b9f87d2febb75efb01d36e7260cb3dc159..db84c8343e164c7ec021106eba1d74291e7f6817 100644 (file)
@@ -71,6 +71,11 @@ uci_set_state() {
        /sbin/uci ${UCI_CONFIG_DIR:+-c $UCI_CONFIG_DIR} -P /var/state set "$PACKAGE.$CONFIG${OPTION:+.$OPTION}=$VALUE"
 }
 
+uci_toggle_state() {
+       uci_revert_state "$1" "$2" "$3"
+       uci_set_state "$1" "$2" "$3" "$4"
+}
+
 uci_set() {
        local PACKAGE="$1"
        local CONFIG="$2"