x86: image: fix small disk space in squashfs overlay
authorPetr Štetiar <ynezz@true.cz>
Thu, 28 Mar 2019 15:05:25 +0000 (15:05 +0000)
committerPetr Štetiar <ynezz@true.cz>
Tue, 25 Jun 2019 14:12:22 +0000 (14:12 +0000)
Current squashfs snapshot images are improperly padded by just 128k,
which doesn't correspond with TARGET_ROOTFS_PARTSIZE=128 default config
option, leading to following:

 Filesystem                Size      Used Available Use% Mounted on
 /dev/root                 2.5M      2.5M         0 100% /rom
 /dev/loop0               85.0K      9.0K     71.0K  11% /overlay
 overlayfs:/overlay       85.0K      9.0K     71.0K  11% /

Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/x86/image/Makefile

index 0771547f29a52b463db43fc45150e4201847bbbe..24825f2ba2c25eb471455563154b7c75d4b09559 100644 (file)
@@ -93,10 +93,6 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
   endef
 endif
 
-define Image/Build/squashfs
-       dd if=/dev/zero bs=128k count=1 >> $(KDIR)/root.squashfs
-endef
-
 define Image/Build/iso
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
@@ -146,14 +142,7 @@ define Image/Build/gzip
        gzip -f9n $(BIN_DIR)/$(IMG_ROOTFS)-$(1).img
 endef
 
-ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
-  define Image/Build/gzip/ext4
-       $(call Image/Build/gzip,ext4)
-  endef
-  define Image/Build/gzip/squashfs
-       $(call Image/Build/gzip,squashfs)
-  endef
-endif
+$(eval $(call Image/gzip-ext4-padded-squashfs))
 
 define Image/BuildKernel
        $(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz