add a build preeq check for glibc-static
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 10 Aug 2012 23:35:20 +0000 (23:35 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 10 Aug 2012 23:35:20 +0000 (23:35 +0000)
SVN-Revision: 33121

include/prereq-build.mk

index 228fcdcb0bfa972b25ff5099a8f43c01c63c3e0c..28c2a216b25692b8f2cba36dc89b62d044f741da 100644 (file)
@@ -70,6 +70,15 @@ $(eval $(call Require,working-g++, \
        Please install the GNU C++ Compiler (g++). \
 ))
 
+define Require/working-gcc-static
+       echo 'int main(int argc, char **argv) { return 0; }' | \
+               gcc -x c -static -o $(TMP_DIR)/a.out -
+endef
+
+$(eval $(call Require,working-gcc-static, \
+    Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL). \
+))
+
 define Require/ncurses
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
                gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses