build: make GCC version 6+ minimal host build requirement
authorPetr Štetiar <ynezz@true.cz>
Mon, 1 Mar 2021 12:27:17 +0000 (13:27 +0100)
committerPetr Štetiar <ynezz@true.cz>
Wed, 3 Mar 2021 21:51:39 +0000 (22:51 +0100)
Currently minimal GNU supported GCC version is 7 (from May 2, 2017),
buildbots are using default GCC version 6 on Debian 9 (old stable),
current Debian stable has GCC version 8.3.0.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
README.md
include/prereq-build.mk

index b30819205be77c62cbf08299820dd00a99d182cf..cb4b0436552a9cc1f03341104e26c259c4e60fba 100644 (file)
--- a/README.md
+++ b/README.md
@@ -25,7 +25,7 @@ the [Build System Setup](https://openwrt.org/docs/guide-developer/build-system/i
 documentation.
 
 ```
-gcc binutils bzip2 flex python3 perl make4.1+ find grep diff unzip gawk getopt
+gcc-6+ binutils bzip2 flex python3 perl make4.1+ find grep diff unzip gawk getopt
 subversion libz-dev libc-dev rsync
 ```
 
index f88e853b52038d24e2db82fc13adc4b6c5f74214..8a6c4bb4684013d343e1f03f1b1ea995a68b9216 100644 (file)
@@ -25,21 +25,21 @@ $(eval $(call TestHostCommand,proper-umask, \
 
 ifndef IB
 $(eval $(call SetupHostCommand,gcc, \
-       Please install the GNU C Compiler (gcc) 4.8 or later, \
-       $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
-       gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+       Please install the GNU C Compiler (gcc) 6 or later, \
+       $(CC) -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
+       gcc -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
        gcc --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-gcc, \
-       \nPlease reinstall the GNU C Compiler (4.8 or later) - \
+       \nPlease reinstall the GNU C Compiler (6 or later) - \
        it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -))
 
 $(eval $(call SetupHostCommand,g++, \
-       Please install the GNU C++ Compiler (g++) 4.8 or later, \
-       $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
-       g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+       Please install the GNU C++ Compiler (g++) 6 or later, \
+       $(CXX) -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
+       g++ -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
        g++ --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-g++, \