brcm63xx: Use model name for ADB P.DG A4001N1
authorJonas Gorski <jogo@openwrt.org>
Sat, 12 Jul 2014 12:31:30 +0000 (12:31 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sat, 12 Jul 2014 12:31:30 +0000 (12:31 +0000)
This patch also makes use of the new leds script.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 41585

13 files changed:
target/linux/brcm63xx/base-files/etc/uci-defaults/01_leds
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.10/530-board_963281T_TEF.patch [deleted file]
target/linux/brcm63xx/patches-3.10/530-board_A4001N1.patch [new file with mode: 0644]
target/linux/brcm63xx/patches-3.10/531-board_96328A-1441N1.patch
target/linux/brcm63xx/patches-3.10/532-board_96328a-1241N.patch
target/linux/brcm63xx/patches-3.10/536-board_fast2704.patch
target/linux/brcm63xx/patches-3.14/530-board_963281T_TEF.patch [deleted file]
target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch [new file with mode: 0644]
target/linux/brcm63xx/patches-3.14/531-board_96328A-1441N1.patch
target/linux/brcm63xx/patches-3.14/532-board_96328a-1241N.patch
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch

index 6007e382183603102914f9bf93d72f2824f786a4..ae7ed96093c6b2d34f32d337aa6b8a05b2ee5211 100644 (file)
@@ -1,14 +1,16 @@
 #!/bin/sh
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
 #
 
-                                                                                                                                                                             
 . /lib/functions/uci-defaults.sh
 . /lib/brcm63xx.sh
 
-
 case "$board_name" in
+963281T_TEF)
+       ucidef_set_led_netdev "lan" "LAN" "A4001N1:green:eth" "eth0"
+       ucidef_set_led_usbdev "usb" "USB" "A4001N1:green:3g" "1-1"
+       ;;
 'F@ST2704V2')
        ucidef_set_led_usbdev "usb" "USB" "F@ST2704V2:green:usb" "1-1"
        ;;
index c6b2d205403692a1efb2d5e0f55a6f37a4247f22..afacffcd9add4a4c0f546bcc1a1c5b6a4cdf4452 100755 (executable)
@@ -54,7 +54,7 @@ brcm63xx_detect() {
                ;;
        963281T_TEF)
                brcm63xx_has_reset_button="true"
-               status_led="963281T_TEF:green:power"
+               status_led="A4001N1:green:power"
                ifname=eth0
                ;;
        96348GW)
index e0c77b675bf988cf533cdba55fbb47268a736ec9..711c80219a4b5942a69e4195fe7aad843499e419 100755 (executable)
@@ -173,7 +173,6 @@ define Image/Build
        $(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-4M-flash-generic,,--pad 2)
        $(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-8M-flash-generic,,--pad 4)
        $(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-16M-flash-generic,,--pad 8)
-       $(call Image/Build/CFE,$(1),963281T_TEF,6328,963281T_TEF-generic,,--pad 8)
        $(call Image/Build/CFE,$(1),96345GW2,6345,96345GW2-generic)
        $(call Image/Build/CFE,$(1),96345GW2,6345,96348GW2-bc221,,--layoutver 5)
        $(call Image/Build/CFE,$(1),96345GW2,6345,92345GW2-rev,OpenWRT-$(REVISION))
@@ -190,6 +189,8 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96368MVNgr,6368,96368MVNgr-generic)
        $(call Image/Build/CFE,$(1),96368MVWG,6368,96368MVWG-generic)
 
+       # ADB P.DG A4001N1
+       $(call Image/Build/CFE,$(1),963281T_TEF,6328,A4001N1,,--pad 8)
        # Asmax AR 1004g
        $(call Image/Build/CFEFIXUP,$(1),96348GW-10,AR1004G,6348,AR1004G)
        # BT Voyager V210_BTR
diff --git a/target/linux/brcm63xx/patches-3.10/530-board_963281T_TEF.patch b/target/linux/brcm63xx/patches-3.10/530-board_963281T_TEF.patch
deleted file mode 100644 (file)
index 134cff6..0000000
+++ /dev/null
@@ -1,137 +0,0 @@
---- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
-+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -235,6 +235,126 @@ static struct board_info __initdata boar
-       },
- };
-+static struct board_info __initdata board_963281T_TEF = {
-+      .name                                   = "963281T_TEF",
-+      .expected_cpu_id                        = 0x6328,
-+
-+      .has_uart0                              = 1,
-+      .has_pci                                = 1,
-+      .has_ohci0                              = 1,
-+      .has_ehci0                              = 1,
-+      .num_usbh_ports                         = 1,
-+      .has_enetsw                             = 1,
-+
-+      .enetsw = {
-+              .used_ports = {
-+                      [0] = {
-+                              .used           = 1,
-+                              .phy_id         = 1,
-+                              .name           = "Port 1",
-+                      },
-+                      [1] = {
-+                              .used           = 1,
-+                              .phy_id         = 2,
-+                              .name           = "Port 2",
-+                      },
-+                      [2] = {
-+                              .used           = 1,
-+                              .phy_id         = 3,
-+                              .name           = "Port 3",
-+                      },
-+                      [3] = {
-+                              .used           = 1,
-+                              .phy_id         = 4,
-+                              .name           = "Port 4",
-+                      },
-+              },
-+      },
-+
-+      .leds = {
-+              {
-+                      .name                   = "963281T_TEF:green:power",
-+                      .gpio                   = 4,
-+                      .active_low             = 1,
-+                      .default_trigger        = "default-on",
-+              },
-+              {
-+                      .name                   = "963281T_TEF:red:power",
-+                      .gpio                   = 8,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:green:inet",
-+                      .gpio                   = 11,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:red:inet",
-+                      .gpio                   = 2,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:green:ppp",
-+                      .gpio                   = 3,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:red:ppp",
-+                      .gpio                   = 5,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:green:3g",
-+                      .gpio                   = 6,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:red:3g",
-+                      .gpio                   = 7,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:green:wlan",
-+                      .gpio                   = 9,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:red:wlan",
-+                      .gpio                   = 10,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:green:eth",
-+                      .gpio                   = 31,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:red:eth",
-+                      .gpio                   = 20,
-+                      .active_low             = 1,
-+              },
-+      },
-+
-+      .buttons = {
-+              {
-+                      .desc                   = "reset",
-+                      .gpio                   = 23,
-+                      .active_low             = 1,
-+                      .type                   = EV_KEY,
-+                      .code                   = KEY_RESTART,
-+                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
-+              },
-+              {
-+                      .desc                   = "wlan",
-+                      .gpio                   = 24,
-+                      .active_low             = 1,
-+                      .type                   = EV_KEY,
-+                      .code                   = KEY_WLAN,
-+                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
-+              },
-+      },
-+};
-+
- static struct board_info __initdata board_dsl_274xb_f1 = {
-       .name                           = "AW4339U",
-       .expected_cpu_id                = 0x6328,
-@@ -2960,6 +3080,7 @@ static const struct board_info __initcon
- #ifdef CONFIG_BCM63XX_CPU_6328
-       &board_96328avng,
-       &board_963281TAN,
-+      &board_963281T_TEF,
-       &board_dsl_274xb_f1,
- #endif
- #ifdef CONFIG_BCM63XX_CPU_6338
diff --git a/target/linux/brcm63xx/patches-3.10/530-board_A4001N1.patch b/target/linux/brcm63xx/patches-3.10/530-board_A4001N1.patch
new file mode 100644 (file)
index 0000000..ea2cb1d
--- /dev/null
@@ -0,0 +1,137 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -235,6 +235,126 @@ static struct board_info __initdata boar
+       },
+ };
++static struct board_info __initdata board_A4001N1 = {
++      .name                                   = "963281T_TEF",
++      .expected_cpu_id                        = 0x6328,
++
++      .has_uart0                              = 1,
++      .has_pci                                = 1,
++      .has_ohci0                              = 1,
++      .has_ehci0                              = 1,
++      .num_usbh_ports                         = 1,
++      .has_enetsw                             = 1,
++
++      .enetsw = {
++              .used_ports = {
++                      [0] = {
++                              .used           = 1,
++                              .phy_id         = 1,
++                              .name           = "Port 1",
++                      },
++                      [1] = {
++                              .used           = 1,
++                              .phy_id         = 2,
++                              .name           = "Port 2",
++                      },
++                      [2] = {
++                              .used           = 1,
++                              .phy_id         = 3,
++                              .name           = "Port 3",
++                      },
++                      [3] = {
++                              .used           = 1,
++                              .phy_id         = 4,
++                              .name           = "Port 4",
++                      },
++              },
++      },
++
++      .leds = {
++              {
++                      .name                   = "A4001N1:green:power",
++                      .gpio                   = 4,
++                      .active_low             = 1,
++                      .default_trigger        = "default-on",
++              },
++              {
++                      .name                   = "A4001N1:red:power",
++                      .gpio                   = 8,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:green:inet",
++                      .gpio                   = 11,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:red:inet",
++                      .gpio                   = 2,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:green:ppp",
++                      .gpio                   = 3,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:red:ppp",
++                      .gpio                   = 5,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:green:3g",
++                      .gpio                   = 6,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:red:3g",
++                      .gpio                   = 7,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:green:wlan",
++                      .gpio                   = 9,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:red:wlan",
++                      .gpio                   = 10,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:green:eth",
++                      .gpio                   = 31,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:red:eth",
++                      .gpio                   = 20,
++                      .active_low             = 1,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc                   = "reset",
++                      .gpio                   = 23,
++                      .active_low             = 1,
++                      .type                   = EV_KEY,
++                      .code                   = KEY_RESTART,
++                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++              },
++              {
++                      .desc                   = "wlan",
++                      .gpio                   = 24,
++                      .active_low             = 1,
++                      .type                   = EV_KEY,
++                      .code                   = KEY_WLAN,
++                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++              },
++      },
++};
++
+ static struct board_info __initdata board_dsl_274xb_f1 = {
+       .name                           = "AW4339U",
+       .expected_cpu_id                = 0x6328,
+@@ -2960,6 +3080,7 @@ static const struct board_info __initcon
+ #ifdef CONFIG_BCM63XX_CPU_6328
+       &board_96328avng,
+       &board_963281TAN,
++      &board_A4001N1,
+       &board_dsl_274xb_f1,
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6338
index dad94a148daee3e85b7163a269c2414fe98fab17..8c67994e6b0354b46408531cec72e6bfade01d5c 100644 (file)
@@ -86,5 +86,5 @@
        &board_96328avng,
 +      &board_96328A_1441N1,
        &board_963281TAN,
-       &board_963281T_TEF,
+       &board_A4001N1,
        &board_dsl_274xb_f1,
index c22d725dc9d2b9850b8b466af17c28cc0fc6b1ec..6866c84f0855c1616d50b24ddc80f1cf9827aa62 100644 (file)
@@ -81,4 +81,4 @@
 +      &board_96328A_1241N,
        &board_96328A_1441N1,
        &board_963281TAN,
-       &board_963281T_TEF,
+       &board_A4001N1,
index 484e4718467d667c549c6da9664ff9a1ad62f612..d377d8be05495f66a07573f691776cc654c43a02 100644 (file)
@@ -137,7 +137,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
        .expected_cpu_id                = 0x6348,
 @@ -3814,6 +3930,7 @@ static const struct board_info __initcon
        &board_963281TAN,
-       &board_963281T_TEF,
+       &board_A4001N1,
        &board_dsl_274xb_f1,
 +      &board_FAST2704V2,
  #endif
diff --git a/target/linux/brcm63xx/patches-3.14/530-board_963281T_TEF.patch b/target/linux/brcm63xx/patches-3.14/530-board_963281T_TEF.patch
deleted file mode 100644 (file)
index bfa2333..0000000
+++ /dev/null
@@ -1,137 +0,0 @@
---- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
-+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -237,6 +237,126 @@ static struct board_info __initdata boar
-       },
- };
-+static struct board_info __initdata board_963281T_TEF = {
-+      .name                                   = "963281T_TEF",
-+      .expected_cpu_id                        = 0x6328,
-+
-+      .has_uart0                              = 1,
-+      .has_pci                                = 1,
-+      .has_ohci0                              = 1,
-+      .has_ehci0                              = 1,
-+      .num_usbh_ports                         = 1,
-+      .has_enetsw                             = 1,
-+
-+      .enetsw = {
-+              .used_ports = {
-+                      [0] = {
-+                              .used           = 1,
-+                              .phy_id         = 1,
-+                              .name           = "Port 1",
-+                      },
-+                      [1] = {
-+                              .used           = 1,
-+                              .phy_id         = 2,
-+                              .name           = "Port 2",
-+                      },
-+                      [2] = {
-+                              .used           = 1,
-+                              .phy_id         = 3,
-+                              .name           = "Port 3",
-+                      },
-+                      [3] = {
-+                              .used           = 1,
-+                              .phy_id         = 4,
-+                              .name           = "Port 4",
-+                      },
-+              },
-+      },
-+
-+      .leds = {
-+              {
-+                      .name                   = "963281T_TEF:green:power",
-+                      .gpio                   = 4,
-+                      .active_low             = 1,
-+                      .default_trigger        = "default-on",
-+              },
-+              {
-+                      .name                   = "963281T_TEF:red:power",
-+                      .gpio                   = 8,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:green:inet",
-+                      .gpio                   = 11,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:red:inet",
-+                      .gpio                   = 2,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:green:ppp",
-+                      .gpio                   = 3,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:red:ppp",
-+                      .gpio                   = 5,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:green:3g",
-+                      .gpio                   = 6,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:red:3g",
-+                      .gpio                   = 7,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:green:wlan",
-+                      .gpio                   = 9,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:red:wlan",
-+                      .gpio                   = 10,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:green:eth",
-+                      .gpio                   = 31,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "963281T_TEF:red:eth",
-+                      .gpio                   = 20,
-+                      .active_low             = 1,
-+              },
-+      },
-+
-+      .buttons = {
-+              {
-+                      .desc                   = "reset",
-+                      .gpio                   = 23,
-+                      .active_low             = 1,
-+                      .type                   = EV_KEY,
-+                      .code                   = KEY_RESTART,
-+                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
-+              },
-+              {
-+                      .desc                   = "wlan",
-+                      .gpio                   = 24,
-+                      .active_low             = 1,
-+                      .type                   = EV_KEY,
-+                      .code                   = KEY_WLAN,
-+                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
-+              },
-+      },
-+};
-+
- static struct board_info __initdata board_dsl_274xb_f1 = {
-       .name                           = "AW4339U",
-       .expected_cpu_id                = 0x6328,
-@@ -2970,6 +3090,7 @@ static const struct board_info __initcon
- #ifdef CONFIG_BCM63XX_CPU_6328
-       &board_96328avng,
-       &board_963281TAN,
-+      &board_963281T_TEF,
-       &board_dsl_274xb_f1,
- #endif
- #ifdef CONFIG_BCM63XX_CPU_6338
diff --git a/target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch b/target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
new file mode 100644 (file)
index 0000000..4706e8c
--- /dev/null
@@ -0,0 +1,137 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -237,6 +237,126 @@ static struct board_info __initdata boar
+       },
+ };
++static struct board_info __initdata board_A4001N1 = {
++      .name                                   = "963281T_TEF",
++      .expected_cpu_id                        = 0x6328,
++
++      .has_uart0                              = 1,
++      .has_pci                                = 1,
++      .has_ohci0                              = 1,
++      .has_ehci0                              = 1,
++      .num_usbh_ports                         = 1,
++      .has_enetsw                             = 1,
++
++      .enetsw = {
++              .used_ports = {
++                      [0] = {
++                              .used           = 1,
++                              .phy_id         = 1,
++                              .name           = "Port 1",
++                      },
++                      [1] = {
++                              .used           = 1,
++                              .phy_id         = 2,
++                              .name           = "Port 2",
++                      },
++                      [2] = {
++                              .used           = 1,
++                              .phy_id         = 3,
++                              .name           = "Port 3",
++                      },
++                      [3] = {
++                              .used           = 1,
++                              .phy_id         = 4,
++                              .name           = "Port 4",
++                      },
++              },
++      },
++
++      .leds = {
++              {
++                      .name                   = "A4001N1:green:power",
++                      .gpio                   = 4,
++                      .active_low             = 1,
++                      .default_trigger        = "default-on",
++              },
++              {
++                      .name                   = "A4001N1:red:power",
++                      .gpio                   = 8,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:green:inet",
++                      .gpio                   = 11,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:red:inet",
++                      .gpio                   = 2,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:green:ppp",
++                      .gpio                   = 3,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:red:ppp",
++                      .gpio                   = 5,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:green:3g",
++                      .gpio                   = 6,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:red:3g",
++                      .gpio                   = 7,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:green:wlan",
++                      .gpio                   = 9,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:red:wlan",
++                      .gpio                   = 10,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:green:eth",
++                      .gpio                   = 31,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "A4001N1:red:eth",
++                      .gpio                   = 20,
++                      .active_low             = 1,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc                   = "reset",
++                      .gpio                   = 23,
++                      .active_low             = 1,
++                      .type                   = EV_KEY,
++                      .code                   = KEY_RESTART,
++                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++              },
++              {
++                      .desc                   = "wlan",
++                      .gpio                   = 24,
++                      .active_low             = 1,
++                      .type                   = EV_KEY,
++                      .code                   = KEY_WLAN,
++                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++              },
++      },
++};
++
+ static struct board_info __initdata board_dsl_274xb_f1 = {
+       .name                           = "AW4339U",
+       .expected_cpu_id                = 0x6328,
+@@ -2970,6 +3090,7 @@ static const struct board_info __initcon
+ #ifdef CONFIG_BCM63XX_CPU_6328
+       &board_96328avng,
+       &board_963281TAN,
++      &board_A4001N1,
+       &board_dsl_274xb_f1,
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6338
index ca52f346b8a3be3b4c83a36bb655f1e20646d000..ad1f50b42fb84990f554e098bb87a76f7c2178ae 100644 (file)
@@ -86,5 +86,5 @@
        &board_96328avng,
 +      &board_96328A_1441N1,
        &board_963281TAN,
-       &board_963281T_TEF,
+       &board_A4001N1,
        &board_dsl_274xb_f1,
index 267c15f3c286e87cf0177455fff1f48bed94175c..1a9f3c977fbc600f5412a82713f1f9beb9a4fa8b 100644 (file)
@@ -81,4 +81,4 @@
 +      &board_96328A_1241N,
        &board_96328A_1441N1,
        &board_963281TAN,
-       &board_963281T_TEF,
+       &board_A4001N1,
index 4fa9f90507072740c1bd38dc8b62440105c6816b..f187ee4505975a923752f4e78264ddfd014c19e3 100644 (file)
@@ -137,7 +137,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
        .expected_cpu_id                = 0x6348,
 @@ -3824,6 +3940,7 @@ static const struct board_info __initcon
        &board_963281TAN,
-       &board_963281T_TEF,
+       &board_A4001N1,
        &board_dsl_274xb_f1,
 +      &board_FAST2704V2,
  #endif