uboot-mvebu: point to UBOOT_CONFIG when setting options
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Mon, 10 Feb 2020 15:33:27 +0000 (16:33 +0100)
committerPetr Štetiar <ynezz@true.cz>
Sun, 1 Mar 2020 20:36:00 +0000 (21:36 +0100)
The BUILD_VARIANT might differ from UBOOT_CONFIG, so point to a file we
are actually changing. Being here let's call 'Build/Configure/U-Boot'
definition, instead of definig the same command. This'll be more future
proof, if U-Boot configuration procedure will change.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
package/boot/uboot-mvebu/Makefile

index d171daa71730eaaaea54c1a1a588b3cd71c471ed..029018b414e5317b0729028ecdccc460cd2cb81f 100644 (file)
@@ -42,11 +42,11 @@ UBOOT_TARGETS:= \
 Build/Exports:=$(Host/Exports)
 
 define Build/Configure
-       # enable additional options beyond clearfog_defconfig
-       echo CONFIG_NET_RANDOM_ETHADDR=y >> $(PKG_BUILD_DIR)/configs/$(BUILD_VARIANT)_defconfig
-       echo CONFIG_CMD_SETEXPR=y >> $(PKG_BUILD_DIR)/configs/$(BUILD_VARIANT)_defconfig
+       # enable additional options beyond <device>_defconfig
+       echo CONFIG_NET_RANDOM_ETHADDR=y >> $(PKG_BUILD_DIR)/configs/$(UBOOT_CONFIG)_defconfig
+       echo CONFIG_CMD_SETEXPR=y >> $(PKG_BUILD_DIR)/configs/$(UBOOT_CONFIG)_defconfig
 
-       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIGURE_VARS) $(UBOOT_CONFIG)_config
+       $(call Build/Configure/U-Boot)
 endef
 
 define Build/InstallDev