lldpd: add missing lldpcli
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 29 Jan 2014 13:10:35 +0000 (13:10 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 29 Jan 2014 13:10:35 +0000 (13:10 +0000)
lldpd calls on startup lldpcli to configure itself.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
SVN-Revision: 39420

package/network/services/lldpd/Makefile

index baed5e0cf7d4ec8ccf174b4cc188b32b257e5046..49940cdeea691fe28454d6c27cdbee5a5d4db273 100644 (file)
@@ -46,7 +46,7 @@ define Package/lldpd/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lldp{ctl,d} $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lldp{cli,ctl,d} $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
        $(INSTALL_BIN) ./files/lldpd.init $(1)/etc/init.d/lldpd
        $(INSTALL_DATA) ./files/lldpd.config $(1)/etc/config/lldpd