kernel: remove useless AddDepends/crc16 abstraction
authorFelix Fietkau <nbd@openwrt.org>
Sun, 29 Mar 2015 08:12:23 +0000 (08:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 29 Mar 2015 08:12:23 +0000 (08:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45133

package/kernel/linux/modules/001-depends.mk
package/kernel/linux/modules/fs.mk
package/kernel/linux/modules/netsupport.mk
package/kernel/linux/modules/other.mk

index d0ad083662d2b02b620fc03dc149cd1c1facd25b..e845670ec8f6639e8a10278569f2acfea7a4c2a1 100644 (file)
@@ -5,10 +5,6 @@
 # See /LICENSE for more information.
 #
 
-define AddDepends/crc16
-  DEPENDS+= +kmod-lib-crc16 $(1)
-endef
-
 define AddDepends/hid
   DEPENDS+= +kmod-hid $(1)
 endef
index 64182e680d46c6fa813205d80e59d6a6faff3c5a..94d4cf2a53eebf9d2e5e0f51a8efaa0b8a9a6505 100644 (file)
@@ -155,6 +155,9 @@ $(eval $(call KernelPackage,fs-exportfs))
 define KernelPackage/fs-ext4
   SUBMENU:=$(FS_MENU)
   TITLE:=EXT4 filesystem support
+  DEPENDS := \
+    +kmod-lib-crc16 \
+    +kmod-crypto-hash
   KCONFIG:= \
        CONFIG_EXT4_FS \
        CONFIG_JBD2
@@ -163,7 +166,6 @@ define KernelPackage/fs-ext4
        $(LINUX_DIR)/fs/jbd2/jbd2.ko \
        $(LINUX_DIR)/fs/mbcache.ko
   AUTOLOAD:=$(call AutoLoad,30,mbcache jbd2 ext4,1)
-  $(call AddDepends/crc16, +kmod-crypto-hash)
 endef
 
 define KernelPackage/fs-ext4/description
index 4ac23c660cfb3626c5e7e6a7b2cbfffc4c05a225..0d70a88a050057c7344acc746aacaf4d18930c6f 100644 (file)
@@ -825,6 +825,7 @@ $(eval $(call KernelPackage,sched))
 define KernelPackage/ax25
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=AX25 support
+  DEPENDS:=+kmod-lib-crc16
   KCONFIG:= \
        CONFIG_HAMRADIO=y \
        CONFIG_AX25 \
@@ -833,7 +834,6 @@ define KernelPackage/ax25
        $(LINUX_DIR)/net/ax25/ax25.ko \
        $(LINUX_DIR)/drivers/net/hamradio/mkiss.ko
   AUTOLOAD:=$(call AutoLoad,80,ax25 mkiss)
-  $(call AddDepends/crc16)
 endef
 
 define KernelPackage/ax25/description
index 86770b5a3bdbd8fca71ada5f8ff4094476db9035..1644f77ce44261c8232ccf439e596c0bd2a063cd 100644 (file)
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,6lowpan-iphc))
 define KernelPackage/bluetooth
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Bluetooth support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc +kmod-lib-crc16
   KCONFIG:= \
        CONFIG_BLUEZ \
        CONFIG_BLUEZ_L2CAP \
@@ -50,7 +50,6 @@ define KernelPackage/bluetooth
        CONFIG_BT_HCIUART_H4 \
        CONFIG_BT_HIDP \
        CONFIG_HID_SUPPORT=y
-  $(call AddDepends/crc16)
   $(call AddDepends/hid)
   $(call AddDepends/rfkill)
   FILES:= \