add broadcom-wl patchtable again
authorFelix Fietkau <nbd@openwrt.org>
Sat, 27 Jan 2007 10:09:53 +0000 (10:09 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 27 Jan 2007 10:09:53 +0000 (10:09 +0000)
SVN-Revision: 6215

package/broadcom-wl/Makefile

index fd6671b28945462c0cd7f0b3d72c3605d895423e..132b69ca2dca5bad1e0119d6bf0137bd717dd81e 100644 (file)
@@ -81,6 +81,20 @@ define Package/nas
        proprietary Broadcom wl driver.
 endef
 
+
+define install_template
+       $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/kmod/wl$(2).o.patch $(1)/lib/modules/$(LINUX_VERSION)/
+endef
+
+define KernelPackage/brcm-wl/install
+       $(call install_template,$(1),)
+endef
+
+define KernelPackage/brcm-wl_mimo/install
+       $(call install_template,$(1),_mimo)
+endef
+
 MAKEFLAGS_KMOD:= -C "$(LINUX_DIR)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                ARCH="$(LINUX_KARCH)" \