brcm47xx: remove versions from linksys-e1000 target
authorMoritz Warning <moritzwarning@web.de>
Sat, 9 Dec 2017 01:57:51 +0000 (02:57 +0100)
committerMathias Kresin <dev@kresin.me>
Mon, 11 Dec 2017 11:44:50 +0000 (12:44 +0100)
The target name does not need to included a revision
if all revisions are supported.
This target supports all revisions (v1, v2, v2.1).

Signed-off-by: Moritz Warning <moritzwarning@web.de>
[Keep the version numbers in the device title, it doesn't harm]
Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/brcm47xx/image/Makefile

index ccd6f4dc44e5ca8ef91a1e5bbcfc6dddd4aa8ff3..284e1f7c05745b8a1162cdc0c420f9030acb86cc 100644 (file)
@@ -701,14 +701,14 @@ define Device/linksys-e900-v1
 endef
 TARGET_DEVICES += linksys-e900-v1
 
-define Device/linksys-e1000-v1-v2-v2.1
+define Device/linksys-e1000
   DEVICE_TITLE := Linksys E1000 v1 v2 v2.1
   DEVICE_PACKAGES := kmod-b43
   $(Device/linksys)
   DEVICE_ID := E100
   VERSION := 1.1.3
 endef
-TARGET_DEVICES += linksys-e1000-v1-v2-v2.1
+TARGET_DEVICES += linksys-e1000
 
 define Device/linksys-e1200-v1
   DEVICE_TITLE := Linksys E1200 v1