use gcc 4.0.2 and deselect ppp by default for Aruba, use gcc 3.4.5 for the other...
authorImre Kaloz <kaloz@openwrt.org>
Fri, 10 Feb 2006 11:04:44 +0000 (11:04 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 10 Feb 2006 11:04:44 +0000 (11:04 +0000)
SVN-Revision: 3210

openwrt/package/ppp/Config.in
openwrt/toolchain/gcc/Config.in

index 3ac1498..1880200 100644 (file)
@@ -3,6 +3,7 @@ menu "ppp............................... PPP (Point-to-Point Protocol) daemon"
 config BR2_PACKAGE_PPP
        prompt "ppp............................... PPP (Point-to-Point Protocol) daemon"
        tristate
+       default n if BR2_LINUX_2_6_ARUBA
        default y
        select BR2_PACKAGE_KMOD_PPP
 
index bec032e..5a6a691 100644 (file)
@@ -14,7 +14,8 @@ config BR2_GCC_3_4
 
 choice
        prompt "GCC compiler Version" if CONFIG_DEVEL
-       default BR2_GCC_VERSION_3_4_4
+       default BR2_GCC_VERSION_4_0_2 if BR2_LINUX_2_6_ARUBA
+       default BR2_GCC_VERSION_3_4_5
        help
          Select the version of gcc you wish to use.
 
@@ -35,8 +36,8 @@ endchoice
 
 config BR2_GCC_VERSION
        string
-       default "3.4.4"     if BR2_GCC_VERSION_3_4_4 || !CONFIG_DEVEL
-       default "3.4.5"     if BR2_GCC_VERSION_3_4_5
+       default "3.4.4"     if BR2_GCC_VERSION_3_4_4
+       default "3.4.5"     if BR2_GCC_VERSION_3_4_5 || !CONFIG_DEVEL
        default "4.0.2"     if BR2_GCC_VERSION_4_0_2