ubox: add explicit dependency on libubus to catch ABI changes
authorFelix Fietkau <nbd@openwrt.org>
Sun, 29 Jun 2014 15:41:39 +0000 (15:41 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 29 Jun 2014 15:41:39 +0000 (15:41 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 41389

package/system/ubox/Makefile

index 9128a8d8e67bf2fe57f1cd4b9b9ec1b412d56e59..5a94f6b37945c7b82da40d825c4a8c42084b54aa 100644 (file)
@@ -24,7 +24,7 @@ TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
 define Package/ubox
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+libubox +ubusd +ubus +libuci +USE_EGLIBC:librt
+  DEPENDS:=+libubox +ubusd +ubus +libubus +libuci +USE_EGLIBC:librt
   TITLE:=OpenWrt system helper toolbox
 endef