ath79: add support for OCEDO Koala
authorDavid Bauer <mail@david-bauer.net>
Wed, 8 Aug 2018 20:13:44 +0000 (22:13 +0200)
committerMathias Kresin <dev@kresin.me>
Thu, 9 Aug 2018 16:44:57 +0000 (18:44 +0200)
This commit adds support for the OCEDO Koala

SOC: Qualcomm QCA9558 (Scorpion)
RAM:    128MB
FLASH:  16MiB
WLAN1:  QCA9558 2.4 GHz 802.11bgn 3x3
WLAN2:  QCA9880 5 GHz 802.11nac 3x3
INPUT:  RESET button
LED:    Power, LAN, WiFi 2.4, WiFi 5, SYS
Serial: Header Next to Black metal shield
        Pinout is 3.3V - GND - TX - RX (Arrow Pad is 3.3V)
        The Serial setting is 115200-8-N-1.

Tested and working:
 - Ethernet
 - 2.4 GHz WiFi
 - 5 GHz WiFi
 - TFTP boot from ramdisk image
 - Installation via ramdisk image
 - OpenWRT sysupgrade
 - Buttons
 - LEDs

Installation seems to be possible only through booting an OpenWRT
ramdisk image.

Hold down the reset button while powering on the device. It will load a
ramdisk image named 'koala-uImage-initramfs-lzma.bin' from 192.168.100.8.

Note: depending on the present software, the device might also try to
pull a file called 'koala-uimage-factory'. Only the name differs, it
is still used as a ramdisk image.

Wait for the ramdisk image to boot. OpenWRT can be written to the flash
via sysupgrade or mtd.

Due to the flip-flop bootloader which we not (yet) support, you need to
set the partition the bootloader is selecting. It is possible from the
initramfs image with

 > fw_setenv bootcmd run bootcmd_1

Afterwards you can reboot the device.

Signed-off-by: David Bauer <mail@david-bauer.net>
package/boot/uboot-envtools/files/ath79
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9558_ocedo_koala.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index 4d9d2e8fe05d779fa7064069af4ae497b042df0d..aa0bf4514fad8cd0d75c85b7b79f5057dd11a852 100644 (file)
@@ -14,6 +14,7 @@ board=$(board_name)
 
 case "$board" in
 glinet,ar300m|\
+ocedo,koala|\
 ocedo,raccoon|\
 openmesh,om5p-ac-v2)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x10000" "0x10000"
index 573bc80462aefe4f82f06c871f00313f4614a2e6..bbb30aa0cc615ae7d3376b408ea0a1b9d712c0ae 100755 (executable)
@@ -10,6 +10,7 @@ ath79_setup_interfaces()
 
        case "$board" in
        avm,fritz300e|\
+       ocedo,koala|\
        ocedo,raccoon|\
        pcs,cap324|\
        tplink,re450-v2|\
index 038573f3e8a14a71ded79b5b67950b3e0a2a0c23..57d9744af20c768657ec8a109667f3935cb473f1 100644 (file)
@@ -87,6 +87,10 @@ board=$(board_name)
 case "$FIRMWARE" in
 "ath10k/cal-pci-0000:00:00.0.bin")
        case $board in
+       ocedo,koala)
+               ath10kcal_extract "art" 20480 2116
+               ath10kcal_patch_mac $(mtd_get_mac_binary art 12)
+               ;;
        openmesh,om5p-ac-v2)
                ath10kcal_extract "ART" 20480 2116
                ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
diff --git a/target/linux/ath79/dts/qca9558_ocedo_koala.dts b/target/linux/ath79/dts/qca9558_ocedo_koala.dts
new file mode 100644 (file)
index 0000000..6020e46
--- /dev/null
@@ -0,0 +1,169 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9557.dtsi"
+
+/ {
+       compatible = "ocedo,koala", "qca,qca9557";
+       model = "OCEDO Koala";
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-status = &system;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               power {
+                       label = "koala:green:power";
+                       gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               wifi2 {
+                       label = "koala:yellow:wlan2";
+                       gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+                       default-state = "off";
+               };
+
+               wifi5 {
+                       label = "koala:red:wlan58";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+                       default-state = "off";
+               };
+
+               system: system {
+                       label = "koala:blue:sys";
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <100>;
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&pcie0 {
+       status = "okay";
+};
+
+&uart {
+       status = "okay";
+};
+
+&pll {
+       clocks = <&extosc>;
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                       partition@50000 {
+                               label = "firmware";
+                               reg = <0x050000 0x740000>;
+                       };
+
+                       partition@790000 {
+                               label = "vendor";
+                               reg = <0x790000 0x740000>;
+                               read-only;
+                       };
+
+                       partition@ed0000 {
+                               label = "data";
+                               reg = <0xed0000 0x110000>;
+                               read-only;
+                       };
+
+                       partition@fe0000 {
+                               label = "id";
+                               reg = <0xfe0000 0x010000>;
+                               read-only;
+                       };
+
+                       art: partition@ff0000 {
+                               label = "art";
+                               reg = <0xff0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&art 0x06>;
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy5: ethernet-phy@5 {
+               reg = <5>;
+               phy-mode = "rgmii-rxid";
+
+               at803x-disable-smarteee;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       mtd-mac-address = <&art 0x00>;
+
+       phy-handle = <&phy5>;
+       phy-mode = "rgmii-rxid";
+
+       pll-data = <0xae000000 0xa0000101 0xa0001313>;
+
+       gmac-config {
+               device = <&gmac>;
+
+               rxdv-delay = <3>;
+               rxd-delay = <3>;
+               txen-delay = <0>;
+               txd-delay = <0>;
+               rgmii-enabled = <1>;
+       };
+};
index a6de86eadee8210bee43df5c70dc11974dc440de..614b3371f32e2ecfa1a7fcefff26bc45934b5fb6 100644 (file)
@@ -57,6 +57,16 @@ define Device/glinet_ar300m_nor
 endef
 TARGET_DEVICES += glinet_ar300m_nor
 
+define Device/ocedo_koala
+  ATH_SOC := qca9558
+  DEVICE_TITLE := OCEDO Koala
+  DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
+  SUPPORTED_DEVICES += koala
+  IMAGE_SIZE := 7424k
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += ocedo_koala
+
 define Device/ocedo_raccoon
   ATH_SOC := ar9344
   DEVICE_TITLE := OCEDO Raccoon