package/kernel: i2c: don't skip built-in modules
authorJonas Gorski <jogo@openwrt.org>
Sat, 23 Feb 2013 11:30:30 +0000 (11:30 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sat, 23 Feb 2013 11:30:30 +0000 (11:30 +0000)
Don't skip build-in modules when generating i2c kmod packages, to allow
empty packages to be generated for satisfying dependencies.

Closes #12259.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 35755

package/kernel/modules/i2c.mk

index e1adafdb0c52965c585c4eb1b4c9189a637186c5..e01f93775d25cfa05f217ae2f9e8b3e02c5c0b21 100644 (file)
@@ -8,7 +8,7 @@
 I2C_MENU:=I2C support
 
 ModuleConfVar=$(word 1,$(subst :,$(space),$(1)))
-ModuleFullPath=$(if $(findstring y,$($(call ModuleConfVar,$(1)))),,$(LINUX_DIR)/$(word 2,$(subst :,$(space),$(1))).ko)
+ModuleFullPath=$(LINUX_DIR)/$(word 2,$(subst :,$(space),$(1))).ko
 ModuleKconfig=$(foreach mod,$(1),$(call ModuleConfVar,$(mod)))
 ModuleFiles=$(foreach mod,$(1),$(call ModuleFullPath,$(mod)))
 ModuleAuto=$(call AutoLoad,$(1),$(foreach mod,$(2),$(basename $(notdir $(call ModuleFullPath,$(mod))))),$(3))