iwinfo: make 'type' visible in wrapped iwinfo
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 18 Oct 2013 11:42:43 +0000 (11:42 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 18 Oct 2013 11:42:43 +0000 (11:42 +0000)
There are several cases within 'luci' that attempt to access the interface
'type' from within the 'type' specific meta tables; however, 'type' is not
currently available there.  Replicate the common metadata in the 'type'
specific meta tables.

Signed-off-by: Nathan Hintz <nlhintz@hotmail.com>
SVN-Revision: 38448

package/network/utils/iwinfo/Makefile
package/network/utils/iwinfo/src/iwinfo_lua.c

index aa534112ed17f26f9084bc764a190b8ef5b17361..9bebb7a61983f23b7a55bf2b947abb7d639c894b 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_RELEASE:=46
+PKG_RELEASE:=47
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index fc4fd4a126659e96b66973ae819c19f458f57033..3f1f2061ca3ca0950c66ab6094771a816193897f 100644 (file)
@@ -862,6 +862,7 @@ LUALIB_API int luaopen_iwinfo(lua_State *L) {
 
 #ifdef USE_WL
        luaL_newmetatable(L, IWINFO_WL_META);
+       luaL_register(L, NULL, R_common);
        luaL_register(L, NULL, R_wl);
        lua_pushvalue(L, -1);
        lua_setfield(L, -2, "__index");
@@ -870,6 +871,7 @@ LUALIB_API int luaopen_iwinfo(lua_State *L) {
 
 #ifdef USE_MADWIFI
        luaL_newmetatable(L, IWINFO_MADWIFI_META);
+       luaL_register(L, NULL, R_common);
        luaL_register(L, NULL, R_madwifi);
        lua_pushvalue(L, -1);
        lua_setfield(L, -2, "__index");
@@ -878,6 +880,7 @@ LUALIB_API int luaopen_iwinfo(lua_State *L) {
 
 #ifdef USE_NL80211
        luaL_newmetatable(L, IWINFO_NL80211_META);
+       luaL_register(L, NULL, R_common);
        luaL_register(L, NULL, R_nl80211);
        lua_pushvalue(L, -1);
        lua_setfield(L, -2, "__index");
@@ -885,6 +888,7 @@ LUALIB_API int luaopen_iwinfo(lua_State *L) {
 #endif
 
        luaL_newmetatable(L, IWINFO_WEXT_META);
+       luaL_register(L, NULL, R_common);
        luaL_register(L, NULL, R_wext);
        lua_pushvalue(L, -1);
        lua_setfield(L, -2, "__index");