image.mk: use cross toolchain cpp for processing dts file instead of relying on the...
authorFelix Fietkau <nbd@openwrt.org>
Sat, 19 Dec 2015 11:15:41 +0000 (11:15 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 19 Dec 2015 11:15:41 +0000 (11:15 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47937

include/image.mk

index 6b2fb1afd86b7093869e1e3c0656bf5f3f235852..1522dd72c855c4b39bfdd802bdd9ef0e622f0367 100644 (file)
@@ -142,7 +142,7 @@ endef
 # $(3) extra CPP flags
 # $(4) extra DTC flags
 define Image/BuildDTB
 # $(3) extra CPP flags
 # $(4) extra DTC flags
 define Image/BuildDTB
-       $(CPP) -nostdinc -x assembler-with-cpp \
+       $(TARGET_CROSS)cpp -nostdinc -x assembler-with-cpp \
                -I$(DTS_DIR) \
                -I$(DTS_DIR)/include \
                -undef -D__DTS__ $(3) \
                -I$(DTS_DIR) \
                -I$(DTS_DIR)/include \
                -undef -D__DTS__ $(3) \