base-files: honor CONFIG_TARGET_INIT_PATH
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 8 Feb 2016 14:28:50 +0000 (14:28 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 8 Feb 2016 14:28:50 +0000 (14:28 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 48678

package/base-files/Makefile
package/base-files/files/etc/preinit
package/base-files/files/etc/profile
package/base-files/files/sbin/hotplug-call

index bf32f6306a4ca574d6282bc6a76aa9351d49f15c..4e3591a30b0138b670d292092f6e2c9083a44e00 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2015 OpenWrt.org
+# Copyright (C) 2007-2016 OpenWrt.org
 # Copyright (C) 2010 Vertical Communications
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -11,17 +11,18 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=165
+PKG_RELEASE:=166
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=usign/host
 PKG_LICENSE:=GPL-2.0
 
-PKG_CONFIG_DEPENDS := CONFIG_SIGNED_PACKAGES
+PKG_CONFIG_DEPENDS := CONFIG_SIGNED_PACKAGES CONFIG_TARGET_INIT_PATH
 
 include $(INCLUDE_DIR)/package.mk
 
 ifneq ($(DUMP),1)
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) echo $(CONFIG_TARGET_INIT_PATH) | md5s)
   TARGET:=-$(BOARD)
   ifneq ($(wildcard $(PLATFORM_DIR)/base-files-$(PROFILE) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)),)
     TARGET:=$(TARGET)-$(PROFILE)
@@ -70,7 +71,7 @@ define ImageConfigOptions
        mkdir -p $(1)/lib/preinit
        echo 'pi_suppress_stderr="$(CONFIG_TARGET_PREINIT_SUPPRESS_STDERR)"' >$(1)/lib/preinit/00_preinit.conf
        echo 'fs_failsafe_wait_timeout=$(if $(CONFIG_TARGET_PREINIT_TIMEOUT),$(CONFIG_TARGET_PREINIT_TIMEOUT),2)' >>$(1)/lib/preinit/00_preinit.conf
-       echo 'pi_init_path=$(if $(CONFIG_TARGET_INIT_PATH),$(CONFIG_TARGET_INIT_PATH),"/usr/sbin:/usr/bin:/sbin:/bin")' >>$(1)/lib/preinit/00_preinit.conf
+       echo 'pi_init_path="$(TARGET_INIT_PATH)"' >>$(1)/lib/preinit/00_preinit.conf
        echo 'pi_init_env=$(if $(CONFIG_TARGET_INIT_ENV),$(CONFIG_TARGET_INIT_ENV),"")' >>$(1)/lib/preinit/00_preinit.conf
        echo 'pi_init_cmd=$(if $(CONFIG_TARGET_INIT_CMD),$(CONFIG_TARGET_INIT_CMD),"/sbin/init")' >>$(1)/lib/preinit/00_preinit.conf
        echo 'pi_init_suppress_stderr="$(CONFIG_TARGET_INIT_SUPPRESS_STDERR)"' >>$(1)/lib/preinit/00_preinit.conf
@@ -141,6 +142,11 @@ define Package/base-files/install
                $(1)/etc/openwrt_release \
                $(1)/etc/device_info
 
+       $(SED) "s#%PATH%#$(TARGET_INIT_PATH)#g" \
+               $(1)/sbin/hotplug-call \
+               $(1)/etc/preinit \
+               $(1)/etc/profile
+
        mkdir -p $(1)/CONTROL
        mkdir -p $(1)/dev
        mkdir -p $(1)/etc/crontabs
index 31f861edf9f8552c7648d87e2627f3f6c9df784c..181b332f146912b432c6f5c6dedb77f86b01493d 100755 (executable)
@@ -1,10 +1,10 @@
 #!/bin/sh
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 # Copyright (C) 2010 Vertical Communications
 
 [ -z "$PREINIT" ] && exec /sbin/init
 
-export PATH=/usr/sbin:/usr/bin:/sbin:/bin
+export PATH="%PATH%"
 
 pi_ifname=
 pi_ip=192.168.1.1
@@ -20,7 +20,7 @@ fs_failsafe_wait_timeout=2
 
 pi_suppress_stderr="y"
 pi_init_suppress_stderr="y"
-pi_init_path="/usr/sbin:/usr/bin:/sbin:/bin"
+pi_init_path="%PATH%"
 pi_init_cmd="/sbin/init"
 
 . /lib/functions.sh
index 8a55fecb376d58a1e420cef6c6215b2ac9053571..ad8fe12b66acdde9ab9c1b627b1fb38b47fb7463 100644 (file)
@@ -6,7 +6,7 @@ fgrep -sq '/ overlay ro,' /proc/mounts && {
        echo 'Please try to remove files from /overlay/upper/... and reboot!'
 }
 
-export PATH=/usr/sbin:/usr/bin:/sbin:/bin
+export PATH="%PATH%"
 export HOME=$(grep -e "^${USER:-root}:" /etc/passwd | cut -d ":" -f 6)
 export HOME=${HOME:-/root}
 export PS1='\u@\h:\w\$ '
index 743871a3ff4b729d7e0f7903d33604dc9850fb40..28e957c3982ae070c7e8729410f45f160ea8b6a4 100755 (executable)
@@ -1,11 +1,11 @@
 #!/bin/sh
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 
 export HOTPLUG_TYPE="$1"
 
 . /lib/functions.sh
 
-PATH=/usr/sbin:/usr/bin:/sbin:/bin
+PATH="%PATH%"
 LOGNAME=root
 USER=root
 export PATH LOGNAME USER