add nls support modules
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Mon, 3 Oct 2005 00:24:03 +0000 (00:24 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Mon, 3 Oct 2005 00:24:03 +0000 (00:24 +0000)
SVN-Revision: 2037

openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-nls-base.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-nls-cp437.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-nls-cp850.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-nls-iso8859-1.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-nls-utf8.control [new file with mode: 0644]
openwrt/target/linux/linux-2.6/Makefile

index 402c1573f1174d9daea9b543b85caad53930b3ed..0f9a0a27bbd6e93e17fa8edcedebe268c0620328 100644 (file)
@@ -252,6 +252,8 @@ config BR2_PACKAGE_KMOD_IDE
 config BR2_PACKAGE_KMOD_VFAT
        tristate "VFAT filesystem support"
        default m
+       depends on BR2_PACKAGE_KMOD_NLS_BASE
+       depends on BR2_PACKAGE_KMOD_NLS_CP437 || BR2_PACKAGE_KMOD_NLS_CP850
        help
          Kernel modules for VFAT filesystem support
          useful for usb mass storage devices
@@ -360,6 +362,36 @@ config BR2_PACKAGE_KMOD_SCHED
        help
          Kernel schedulers for IP traffic
 
+config BR2_PACKAGE_KMOD_NLS_BASE
+       tristate "basic native language support for filesystems"
+       default m
+       help
+         Kernel native language support
+
+config BR2_PACKAGE_KMOD_NLS_CP437
+       tristate "code page 437"
+       default m
+       help
+         Kernel native language support
+
+config BR2_PACKAGE_KMOD_NLS_CP850
+       tristate "code page 850"
+       default m
+       help
+         Kernel native language support
+
+config BR2_PACKAGE_KMOD_NLS_UTF8
+       tristate "utf8"
+       default m
+       help
+         Kernel native language support
+
+config BR2_PACKAGE_KMOD_NLS_IS08859_1
+       tristate "iso8859-1"
+       default m
+       help
+         Kernel native language support
+
 config BR2_PACKAGE_KMOD_VIDEODEV
        tristate "Video (For Linux) kernel support"
        default m
diff --git a/openwrt/target/linux/control/kmod-nls-base.control b/openwrt/target/linux/control/kmod-nls-base.control
new file mode 100644 (file)
index 0000000..8e5514e
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-nls-base
+Priority: optional
+Section: sys
+Maintainer: Waldemar Brodkorb <wbx@openwrt.org>
+Source: buildroot internal
+Description: Kernel modules for basic native language support
diff --git a/openwrt/target/linux/control/kmod-nls-cp437.control b/openwrt/target/linux/control/kmod-nls-cp437.control
new file mode 100644 (file)
index 0000000..0beb993
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-nls-cp437
+Priority: optional
+Section: sys
+Maintainer: Waldemar Brodkorb <wbx@openwrt.org>
+Source: buildroot internal
+Description: Kernel module for codepage 437
diff --git a/openwrt/target/linux/control/kmod-nls-cp850.control b/openwrt/target/linux/control/kmod-nls-cp850.control
new file mode 100644 (file)
index 0000000..8631ba2
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-nls-cp850
+Priority: optional
+Section: sys
+Maintainer: Waldemar Brodkorb <wbx@openwrt.org>
+Source: buildroot internal
+Description: Kernel module for codepage 850
diff --git a/openwrt/target/linux/control/kmod-nls-iso8859-1.control b/openwrt/target/linux/control/kmod-nls-iso8859-1.control
new file mode 100644 (file)
index 0000000..d4e8825
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-nls-iso8859-1
+Priority: optional
+Section: sys
+Maintainer: Waldemar Brodkorb <wbx@openwrt.org>
+Source: buildroot internal
+Description: Kernel module for iso8859-1 charset support
diff --git a/openwrt/target/linux/control/kmod-nls-utf8.control b/openwrt/target/linux/control/kmod-nls-utf8.control
new file mode 100644 (file)
index 0000000..cbbd14b
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-nls-utf8
+Priority: optional
+Section: sys
+Maintainer: Waldemar Brodkorb <wbx@openwrt.org>
+Source: buildroot internal
+Description: Kernel module for utf8 support
index 33777088ac53226786d551dd9383a17d62043700..544b5c5c73c22c6e93b0fc7eddd960a703d7f733 100644 (file)
@@ -135,7 +135,22 @@ $(eval $(call KMOD_template,VFAT,vfat,\
        $(MODULES_DIR)/kernel/fs/vfat/vfat.ko \
        $(MODULES_DIR)/kernel/fs/fat/fat.ko \
        $(MODULES_DIR)/kernel/fs/nls/nls_base.ko \
-,CONFIG_VFAT_FS,,30,nls_base fat vfat))
+,CONFIG_VFAT_FS,,30,fat vfat))
+$(eval $(call KMOD_template,NLS_BASE,nls-base,\
+       $(MODULES_DIR)/kernel/fs/nls/nls_base.ko \
+,CONFIG_NLS,,20,nls_base))
+$(eval $(call KMOD_template,NLS_UTF8,nls-utf8,\
+       $(MODULES_DIR)/kernel/fs/nls/nls_utf8.ko \
+,CONFIG_NLS_UTF8,,20,nls_utf8))
+$(eval $(call KMOD_template,NLS_ISO8859_1,nls-iso8859-1,\
+       $(MODULES_DIR)/kernel/fs/nls/nls_iso8859-1.ko \
+,CONFIG_NLS_ISO8859_1,,20,nls_iso8859-1))
+$(eval $(call KMOD_template,NLS_CP437,nls-cp437,\
+       $(MODULES_DIR)/kernel/fs/nls/nls_cp437.ko \
+,CONFIG_NLS_CODEPAGE_437,,20,nls_cp437))
+$(eval $(call KMOD_template,NLS_CP850,nls-cp850,\
+       $(MODULES_DIR)/kernel/fs/nls/nls_cp850.ko \
+,CONFIG_NLS_CODEPAGE_850,,20,nls_cp850))
 $(eval $(call KMOD_template,CRYPTO,crypto,\
        $(MODULES_DIR)/kernel/crypto/*.ko \
 ))