ar71xx: use custom LZMA dictionary size for WNDR3700 images
authorGabor Juhos <juhosg@openwrt.org>
Sun, 18 Nov 2012 20:25:13 +0000 (20:25 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 18 Nov 2012 20:25:13 +0000 (20:25 +0000)
Based on a patch by Hannu Nyman.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34248

target/linux/ar71xx/image/Makefile

index 48893e6aac8d6d7ee3a74f785a4922d4027dcfc8..dbda865ec61984af18302bcc4fc514d28ef94ab5 100644 (file)
@@ -69,13 +69,13 @@ ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
 endif
 
 define CompressLzma
-  $(STAGING_DIR_HOST)/bin/lzma e $(1) -lc1 -lp2 -pb2 $(2)
+  $(STAGING_DIR_HOST)/bin/lzma e $(1) -lc1 -lp2 -pb2 $(3) $(2)
 endef
 
 define PatchKernelLzma
        cp $(KDIR)/vmlinux $(KDIR_TMP)/vmlinux-$(1)
        $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR_TMP)/vmlinux-$(1) "$(strip $(2))"
-       $(call CompressLzma,$(KDIR_TMP)/vmlinux-$(1),$(KDIR_TMP)/vmlinux-$(1).bin.lzma)
+       $(call CompressLzma,$(KDIR_TMP)/vmlinux-$(1),$(KDIR_TMP)/vmlinux-$(1).bin.lzma,$(3))
 endef
 
 define PatchKernelGzip
@@ -91,7 +91,7 @@ define MkuImage
 endef
 
 define MkuImageLzma
-       $(call PatchKernelLzma,$(1),$(2))
+       $(call PatchKernelLzma,$(1),$(2),$(3))
        $(call MkuImage,lzma,,$(KDIR_TMP)/vmlinux-$(1).bin.lzma,$(KDIR_TMP)/vmlinux-$(1).uImage)
 endef
 
@@ -579,7 +579,7 @@ define Image/Build/CyberTAN
 endef
 
 define Image/Build/Netgear/Build_uImage
-       $(call MkuImageLzma,$(1),$(2) $(3))
+       $(call MkuImageLzma,$(1),$(2) $(3),-d20)
        -rm -rf $(KDIR)/$(1)
        mkdir -p $(KDIR)/$(1)/image
        $(STAGING_DIR_HOST)/bin/wndr3700 \