ltq-adsl: fix broken autoconf invocation
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 11 Jan 2015 16:53:34 +0000 (16:53 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 11 Jan 2015 16:53:34 +0000 (16:53 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 43931

package/kernel/lantiq/ltq-adsl/Makefile

index 2a9f0de388630559267ce8bf43e4539e5e378fbe..26c931e2a92cc1577a3139ca00ae5111cab5e21f 100644 (file)
@@ -19,6 +19,7 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 PKG_USE_MIPS16:=0
 PKG_CHECK_FORMAT_SECURITY:=0
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -84,11 +85,6 @@ endif
 
 EXTRA_CFLAGS = -fno-pic -mno-abicalls -mlong-calls -G 0
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); aclocal && autoconf && automake)
-       $(call Build/Configure/Default)
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/adsl
        $(CP) $(PKG_BUILD_DIR)/src/include/drv_dsl_cpe_*.h $(1)/usr/include/adsl/