fix EABI kernel config on IOP32x
authorImre Kaloz <kaloz@openwrt.org>
Thu, 3 Apr 2008 13:54:25 +0000 (13:54 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Thu, 3 Apr 2008 13:54:25 +0000 (13:54 +0000)
SVN-Revision: 10720

target/linux/iop32x/Makefile

index ccecf204c8f3e4aac29150ce4f5299b053d816be..82a3367a6a515411dffe26c33c490c261fcaf946 100644 (file)
@@ -15,4 +15,10 @@ LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 
+define Kernel/Configure
+       $(call Kernel/Configure/Default)
+       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
+
 $(eval $(call BuildTarget))