ramips: improve and fix Memory 2 Move support
authorJohn Crispin <john@openwrt.org>
Thu, 22 Jan 2015 09:35:12 +0000 (09:35 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 22 Jan 2015 09:35:12 +0000 (09:35 +0000)
This patch is a follow up for my previous patch:
"ramips: add support for Intenso Memory 2 Move USB 3.0".

It fixes a couple of errors in the DTS (one of which broke
the gpio-buttons). The kmod-leds-gpio dependency has been
dropped as it is already part of the ramips target.

Furthermore the ramdisk/uImage image is generated by default
for the rt3050 subtarget. This image is needed to flash
OpenWrt for the first time onto the device via TFTP.

Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
SVN-Revision: 44072

target/linux/ramips/dts/M2M.dts
target/linux/ramips/rt305x/profiles/m2m.mk
target/linux/ramips/rt305x/target.mk

index aa98991ae1a84c8573ddcce2e4fb428e6fc609eb..41910374c978238386424bf597d13dafb6b4b94a 100644 (file)
@@ -7,14 +7,10 @@
        model = "Intenso Memory 2 Move";
 
        chosen {
-               bootargs = "console=ttyS1,57600n8 root=/dev/mtdblock5";
+               bootargs = "console=ttyS0,57600n8 root=/dev/mtdblock5";
        };
 
        palmbus@10000000 {
-               uart@500 {
-                       status = "okay";
-               };
-
                spi@b00 {
                        status = "okay";
                        m25p80@0 {
@@ -54,7 +50,7 @@
        pinctrl {
                state_default: pinctrl0 {
                        gpio {
-                               ralink,group = "i2c", "jtag", "uartf";
+                               ralink,group = "i2c", "uartf";
                                ralink,function = "gpio";
                        };
                };
        };
 
        gpio-keys-polled {
-               gpio-keys-polled {
                compatible = "gpio-keys-polled";
                #address-cells = <1>;
                #size-cells = <0>;
                poll-interval = <20>;
-                       power {
-                               label = "power";
-                               gpios = <&gpio0 1 1>;
-                               linux,code = <0x116>;
-                       };
-                       reset {
-                               label = "reset";
-                               gpios = <&gpio0 10 1>;
-                               linux,code = <0x198>;
-                       };
+               power {
+                       label = "power";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <0x116>;
+               };
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 10 1>;
+                       linux,code = <0x198>;
                };
        };
 
index ea803baa2537813d1bb5dc700232c237c19ac97b..1b13cc50688954dcc9da282d1de054023fe93d00 100644 (file)
@@ -8,7 +8,7 @@
 define Profile/M2M
        NAME:=Intenso Memory 2 Move
        PACKAGES:=\
-               kmod-ledtrig-netdev kmod-ledtrig-timer kmod-leds-gpio \
+               kmod-ledtrig-netdev kmod-ledtrig-timer \
                kmod-usb-core kmod-usb2 kmod-usb-storage kmod-scsi-core \
                kmod-fs-ext4 kmod-fs-vfat block-mount
 endef
index d0114c15c198adf1481c3c1457eecf24b76a1051..b97554fc7cd0d01b2478f4763213220e9a8251dd 100644 (file)
@@ -5,7 +5,7 @@
 SUBTARGET:=rt305x
 BOARDNAME:=RT3x5x/RT5350 based boards
 ARCH_PACKAGES:=ramips_24kec
-FEATURES+=usb
+FEATURES+=usb ramdisk
 CPU_TYPE:=24kec
 CPU_SUBTYPE:=dsp