opkg: switch to git repository (#14655)
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 21 Dec 2013 13:47:46 +0000 (13:47 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 21 Dec 2013 13:47:46 +0000 (13:47 +0000)
Upstream development now takes place in a git repository which was clone
from the old svn repository. Switch the source location to the git tree
using the commit that corresponds to the old svn r618 revision.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 39153

package/system/opkg/Makefile

index 0669ddf685fd63c13fa747c7d1d65a661fe995de..0dc3d6a7bebc51e3f8a9a6eadcffc8fedd1f7808 100644 (file)
@@ -9,14 +9,14 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=opkg
-PKG_REV:=618
+PKG_REV:=9c97d5ecd795709c8584e972bfdf3aee3a5b846d
 PKG_VERSION:=$(PKG_REV)
 PKG_RELEASE:=6
 
-PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_PROTO:=git
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_SUBDIR:=opkg-$(PKG_VERSION)
-PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
+PKG_SOURCE_URL:=http://git.yoctoproject.org/git/opkg
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_FIXUP:=autoreconf