ar71xx: fix new mktplinkfw image code - flags for sysupgrade vs factory were swapped...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 6 Apr 2015 19:26:30 +0000 (19:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 6 Apr 2015 19:26:30 +0000 (19:26 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45281

target/linux/ar71xx/image/Makefile

index 9459683afb96bb7b6cbc831afed0611046781fd9..8766756871de5f7001807aeaa06e31e477efbcd2 100644 (file)
@@ -57,8 +57,8 @@ define Build/mktplinkfw
                -r $@ \
                -o $@.new \
                -a $(call rootfs_align,$(FILESYSTEM)) \
-               $(if $(findstring sysupgrade,$1),-j -X 0x40000) \
-               $(if $(findstring factory,$1),-j -X 0x40000 -s) \
+               $(if $(findstring sysupgrade,$1),-j -X 0x40000 -s) \
+               $(if $(findstring factory,$1),-j -X 0x40000) \
                $(if $(findstring initramfs,$1),-s -c)
        @mv $@.new $@
 endef