revert my changes. didn't work
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Sun, 4 Sep 2005 00:13:34 +0000 (00:13 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Sun, 4 Sep 2005 00:13:34 +0000 (00:13 +0000)
SVN-Revision: 1842

openwrt/package/mtd/Makefile
openwrt/package/mtd/mtd.c

index b2090a6e49a6b35739c8576cdc08b377fe31328f..bfbb301e4c867fb2bc72440ac7e8421535a4deb9 100644 (file)
@@ -7,10 +7,6 @@ PKG_RELEASE := 1
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-ifeq ($(LINUX_VERSION),2.4.30)
-VER=-DLINUX_24
-endif
-
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
@@ -20,7 +16,7 @@ $(PKG_BUILD_DIR)/.prepared:
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
-       $(TARGET_CC) -I$(LINUX_DIR)/include $(VER) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
+       $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
        touch $@
 
 $(IPKG_MTD): 
index e5598649452fe3be699d9bf6670a92983cac8b8f..69ef0649608086f162b64a9364ae6e3957b8bc9f 100644 (file)
 #include <sys/reboot.h>
 #include <string.h>
 
-#ifdef LINUX_24
 #include <linux/mtd/mtd.h>
-#else
-#include <mtd/mtd-user.h>
-#endif
 
 #define TRX_MAGIC       0x30524448      /* "HDR0" */
 #define BUFSIZE (10 * 1024)