iwinfo: fix detection of Bullet M5, the PCI ID was wrong
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 16 Feb 2012 17:58:33 +0000 (17:58 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 16 Feb 2012 17:58:33 +0000 (17:58 +0000)
SVN-Revision: 30591

package/iwinfo/Makefile
package/iwinfo/src/iwinfo_lib.c

index 4f6bc1d363d0e0e48a3d5f3cecf70ea46a02cf5e..27caf9fcba15baeb429e0c6c20998277084fa467 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_RELEASE:=24
+PKG_RELEASE:=25
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index e33c7950781810ea83ceaedb864dc18c33ac64de..0e919861cac1ee6d6791d29269cef7223473d45d 100644 (file)
@@ -351,7 +351,7 @@ const struct iwinfo_hardware_entry IWINFO_HARDWARE_ENTRIES[] = {
        { VENDOR_UBNT, "NanoStation M2",        0x168c, 0x002a, 0x0777, 0xe012, 10,     0 }, /* ToDo: confirm offset */
        { VENDOR_UBNT, "NanoStation M5",        0x168c, 0x002a, 0x0777, 0xe005,  5,     0 }, /* ToDo: confirm offset */
        { VENDOR_UBNT, "Bullet M2",             0x168c, 0x002a, 0x0777, 0xe202, 12,     0 },
-       { VENDOR_UBNT, "Bullet M5",             0x168c, 0x002a, 0x0777, 0xe205,  5,     0 },
+       { VENDOR_UBNT, "Bullet M5",             0x168c, 0x002a, 0x0777, 0xe805,  5,     0 },
 
        { VENDOR_ATH,  "AR9220",                0x168c, 0x0029, 0x168c, 0xa094,  0,     0 },
        { VENDOR_ATH,  "AR9223",                0x168c, 0x0029, 0x168c, 0xa095,  0,     0 },