Revert "kernel: add IEEE-1284 parallel port support"
authorJo-Philipp Wich <jo@mein.io>
Mon, 22 Jan 2018 12:41:16 +0000 (13:41 +0100)
committerJo-Philipp Wich <jo@mein.io>
Mon, 22 Jan 2018 12:41:20 +0000 (13:41 +0100)
This reverts commit 666e9cf2220b11ccd024cad13ad54ca71d40c5b3.

The change has not been build-tested on non-x86 targets and leads to
stalled kernel builds due to unset configuration symbols there.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/kernel/linux/modules/other.mk

index 94f98fffc9539b91fedb728db0234f30fe4e45ca..973e4f3e26a57c5d979afe0e9c43796e3ce46188 100644 (file)
@@ -285,51 +285,18 @@ endef
 $(eval $(call KernelPackage,gpio-pcf857x))
 
 
-define KernelPackage/ppdev
+define KernelPackage/lp
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Parallel port support
+  TITLE:=Parallel port and line printer support
   KCONFIG:= \
        CONFIG_PARPORT \
+       CONFIG_PRINTER \
        CONFIG_PPDEV
   FILES:= \
        $(LINUX_DIR)/drivers/parport/parport.ko \
+       $(LINUX_DIR)/drivers/char/lp.ko \
        $(LINUX_DIR)/drivers/char/ppdev.ko
-  AUTOLOAD:=$(call AutoLoad,50,parport ppdev)
-endef
-
-$(eval $(call KernelPackage,ppdev))
-
-
-define KernelPackage/parport-pc
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Parallel port interface (PC-style) support
-  DEPENDS:=+kmod-ppdev
-  KCONFIG:= \
-       CONFIG_PARPORT_PC \
-       CONFIG_PARPORT_1284=y \
-       CONFIG_PARPORT_PC_FIFO=y \
-       CONFIG_PARPORT_PC_SUPERIO=y \
-       CONFIG_PARPORT_SERIAL=n \
-       CONFIG_PARIDE=n \
-       CONFIG_SCSI_IMM=n \
-       CONFIG_SCSI_PPA=n
-  FILES:= \
-       $(LINUX_DIR)/drivers/parport/parport_pc.ko
-  AUTOLOAD:=$(call AutoLoad,51,parport_pc)
-endef
-
-$(eval $(call KernelPackage,parport-pc))
-
-
-define KernelPackage/lp
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Parallel port line printer device support
-  DEPENDS:=+kmod-ppdev
-  KCONFIG:= \
-       CONFIG_PRINTER
-  FILES:= \
-       $(LINUX_DIR)/drivers/char/lp.ko
-  AUTOLOAD:=$(call AutoLoad,52,lp)
+  AUTOLOAD:=$(call AutoLoad,50,parport lp ppdev)
 endef
 
 $(eval $(call KernelPackage,lp))