We $(PLATFORM_SUBDIR)/target.mk gets included, include/kernel-version.mk hasn't yet...
authorDaniel Dickinson <crazycshore@gmail.com>
Sat, 2 Apr 2011 02:02:24 +0000 (02:02 +0000)
committerDaniel Dickinson <crazycshore@gmail.com>
Sat, 2 Apr 2011 02:02:24 +0000 (02:02 +0000)
Ergo, we need to use a deferred definition of GEOS_GPIO (and can't use ifeq/endif).

Signed-off-by: Philip Prindeville <philipp@openwrt.org
SVN-Revision: 26397

target/linux/x86/geos/target.mk

index 324525fbf9e7900a26e50021abc650b96b9a6406..4c03eca65f727989606e0de6cb4ba7818caff400 100644 (file)
@@ -1,10 +1,6 @@
 BOARDNAME:=Traverse Geos
 FEATURES:=squashfs jffs2 ext4 pci usb gpio
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
-  GEOS_GPIO:=gpio-cs5535-new
-else
-  GEOS_GPIO:=gpio-cs5535
-endif
+GEOS_GPIO = $(if $(findstring 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),gpio-cs5535-new,gpio-cs5535)
 DEFAULT_PACKAGES += kmod-ata-via-sata \
             kmod-crypto-hw-geode kmod-crypto-ocf \
             kmod-$(GEOS_GPIO) kmod-gpio-nsc \