ath79: align naming of Ubiquiti Nanostation M
authorSven Roederer <devel-sven@geroedel.de>
Wed, 6 Mar 2019 23:09:15 +0000 (00:09 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Mon, 18 Mar 2019 19:55:24 +0000 (20:55 +0100)
Support for the Nanostation M (XW) was added in 40530c8eb with board
name "nanostation-m-xw". The current image for the "Nanostation M"
uses "nano-m" as the board name.
This commit renames it to the full product name as it's used by all
other boards. The legacy boardname of the ar71xx target is added
via SUPPORTED_DEVICES to ease switching to ath79 target.

Signed-off-by: Sven Roederer <devel-sven@geroedel.de>
[touch-ups on the commit message, removed subject remains]
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/dts/ar7241_ubnt_nano-m.dts [deleted file]
target/linux/ath79/dts/ar7241_ubnt_nanostation-m.dts [new file with mode: 0644]
target/linux/ath79/image/generic-ubnt.mk

index 0b0dda3bcfbd9c1880b55ea8cde7c5020891e56d..db5a6a4578b416adab8045848c55ab0852a02129 100755 (executable)
@@ -155,7 +155,7 @@ tplink,tl-wr841-v11)
        ;;
 ubnt,bullet-m|\
 ubnt,bullet-m-xw|\
-ubnt,nano-m|\
+ubnt,nanostation-m|\
 ubnt,nanostation-m-xw|\
 ubnt,rocket-m)
        ucidef_set_rssimon "wlan0" "200000" "1"
diff --git a/target/linux/ath79/dts/ar7241_ubnt_nano-m.dts b/target/linux/ath79/dts/ar7241_ubnt_nano-m.dts
deleted file mode 100644 (file)
index ebdc430..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include "ar7241_ubnt_xm_outdoor.dtsi"
-
-/ {
-       compatible = "ubnt,nano-m", "ubnt,xm", "qca,ar7241";
-       model = "Ubiquiti Nanostation M";
-};
diff --git a/target/linux/ath79/dts/ar7241_ubnt_nanostation-m.dts b/target/linux/ath79/dts/ar7241_ubnt_nanostation-m.dts
new file mode 100644 (file)
index 0000000..eebe65e
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar7241_ubnt_xm_outdoor.dtsi"
+
+/ {
+       compatible = "ubnt,nanostation-m", "ubnt,xm", "qca,ar7241";
+       model = "Ubiquiti Nanostation M";
+};
index 89b9f6746dada624f528ea0f81fe3e4e5b1160cc..b7e867d8bf2e9dcdbdc930d149793522ab3b3061 100644 (file)
@@ -106,16 +106,17 @@ define Device/ubnt_rocket-m
 endef
 TARGET_DEVICES += ubnt_rocket-m
 
-define Device/ubnt_nano-m
+define Device/ubnt_nanostation-m
   $(Device/ubnt-xm)
-  DEVICE_TITLE := Ubiquiti Nano-M
+  DEVICE_TITLE := Ubiquiti Nanostation M
   SUPPORTED_DEVICES += nano-m
 endef
-TARGET_DEVICES += ubnt_nano-m
+TARGET_DEVICES += ubnt_nanostation-m
 
 define Device/ubnt_nanostation-m-xw
   $(Device/ubnt-xw)
   DEVICE_TITLE := Ubiquiti Nanostation M (XW)
+  SUPPORTED_DEVICES += nano-m-xw
 endef
 TARGET_DEVICES += ubnt_nanostation-m-xw