busybox: procd is now the init process
authorJohn Crispin <john@openwrt.org>
Fri, 21 Jun 2013 16:53:30 +0000 (16:53 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 21 Jun 2013 16:53:30 +0000 (16:53 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 36997

package/busybox/Makefile
package/busybox/config/init/Config.in
package/busybox/config/sysklogd/Config.in

index ed58fabcfd9176d6fd20f1912cca233b523ed42a..aed6ddea6b60a72f4004784c141f6fb64d69a62f 100644 (file)
@@ -17,7 +17,6 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
 PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
 
                http://distfiles.gentoo.org/distfiles/
 PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
 
-PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
 PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
 PKG_BUILD_PARALLEL:=1
 
 PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
 PKG_BUILD_PARALLEL:=1
 
index 4b3c8dd1606152ff822850076827d9ea75a82709..07d94a2056a8ba94f8115e36240aa24c07a5fc95 100644 (file)
@@ -73,7 +73,7 @@ config BUSYBOX_CONFIG_INIT
        bool "init"
        default y
        select BUSYBOX_CONFIG_FEATURE_SYSLOG
        bool "init"
        default y
        select BUSYBOX_CONFIG_FEATURE_SYSLOG
-       depends on !PROCD_INIT
+       depends on BROKEN
        help
          init is the first program run when the system boots.
 
        help
          init is the first program run when the system boots.
 
index 087a5b4e50e19fca509e4d530d1a1659ce7d7e6e..f403a684bb649bc2a5bcb5a7e2e53ab31266cb9b 100644 (file)
@@ -96,7 +96,7 @@ config BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG_BUFFER_SIZE
 config BUSYBOX_CONFIG_LOGREAD
        bool "logread"
        default y
 config BUSYBOX_CONFIG_LOGREAD
        bool "logread"
        default y
-       depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG && !PROCD_INIT
+       depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG && BROKEN
        help
          If you enabled Circular Buffer support, you almost
          certainly want to enable this feature as well. This
        help
          If you enabled Circular Buffer support, you almost
          certainly want to enable this feature as well. This