kernel: bump 3.18 to 3.18.125
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 14 Nov 2018 12:47:36 +0000 (13:47 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 14 Nov 2018 15:27:43 +0000 (16:27 +0100)
Refreshed all patches.

Compile-tested on: adm5120
Compile-tested on: none

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/pending-3.18/192-USB-qcserial-Add-support-for-Quectel-EC20-Mini-PCIe-.patch
target/linux/generic/pending-3.18/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/generic/pending-3.18/834-ledtrig-libata.patch

index 826bab5487f0144f1e2b3091152819635053a2dd..9c436e1bc772042c5025bca6ab27d4b37aeaed78 100644 (file)
@@ -2,11 +2,11 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-3.18 = .124
+LINUX_VERSION-3.18 = .125
 LINUX_VERSION-4.9 = .135
 LINUX_VERSION-4.14 = .80
 
-LINUX_KERNEL_HASH-3.18.124 = 25d2a5abd627534a1e51d028890c184aad8e628c345c5fe0cc0f9d7c31b7a5a3
+LINUX_KERNEL_HASH-3.18.125 = 708433b360efd8623f7303b721ffb0e7c59cbe8552f1a3f4c0d980a12b4ed90e
 LINUX_KERNEL_HASH-4.9.135 = e023b0bbe9ea7fc56aa57210342dd18ea3e0900ee207226df1523c6d7df154ce
 LINUX_KERNEL_HASH-4.14.80 = 9ddc7bc11cbea6475ac5abf18e01a143d7d506bece591e0dcb15c9452d3ed7d2
 
index c75cc9ded154bc00f716b12ee6cbe757deefcd12..02133e4b5e161cac4c5db9f67f73fb6143939098 100644 (file)
@@ -100,7 +100,7 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
  static int qcprobe(struct usb_serial *serial, const struct usb_device_id *id)
  {
        struct usb_host_interface *intf = serial->interface->cur_altsetting;
-@@ -249,6 +283,11 @@ static int qcprobe(struct usb_serial *se
+@@ -253,6 +287,11 @@ static int qcprobe(struct usb_serial *se
                        altsetting = -1;
                break;
        case QCSERIAL_G2K:
index c9686f1f01f88c0f067bb53e16f17c3e8735bacc..9a2808acd5ba97c42780fa3942b2f84549c583d9 100644 (file)
@@ -287,9 +287,9 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        int err;
 +      struct __ip6_tnl_fmr *fmr;
  
-       if ((t->parms.proto != IPPROTO_IPIP && t->parms.proto != 0) ||
-           !ip6_tnl_xmit_ctl(t))
-@@ -1108,6 +1246,18 @@ ip4ip6_tnl_xmit(struct sk_buff *skb, str
+       /* ensure we can access the full inner ip header */
+       if (!pskb_may_pull(skb, sizeof(struct iphdr)))
+@@ -1114,6 +1252,18 @@ ip4ip6_tnl_xmit(struct sk_buff *skb, str
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
                fl6.flowi6_mark = skb->mark;
  
@@ -308,7 +308,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        err = ip6_tnl_xmit2(skb, dev, dsfield, &fl6, encap_limit, &mtu);
        if (err != 0) {
                /* XXX: send ICMP error even if DF is not set. */
-@@ -1276,6 +1426,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
+@@ -1286,6 +1436,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
        t->parms.flowinfo = p->flowinfo;
        t->parms.link = p->link;
        t->parms.proto = p->proto;
@@ -323,7 +323,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        ip6_tnl_dst_reset(t);
        ip6_tnl_link_config(t);
        return 0;
-@@ -1306,6 +1464,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
+@@ -1316,6 +1474,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
        p->flowinfo = u->flowinfo;
        p->link = u->link;
        p->proto = u->proto;
@@ -331,7 +331,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        memcpy(p->name, u->name, sizeof(u->name));
  }
  
-@@ -1581,6 +1740,15 @@ static int ip6_tnl_validate(struct nlatt
+@@ -1591,6 +1750,15 @@ static int ip6_tnl_validate(struct nlatt
        return 0;
  }
  
@@ -347,7 +347,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  static void ip6_tnl_netlink_parms(struct nlattr *data[],
                                  struct __ip6_tnl_parm *parms)
  {
-@@ -1614,6 +1782,46 @@ static void ip6_tnl_netlink_parms(struct
+@@ -1624,6 +1792,46 @@ static void ip6_tnl_netlink_parms(struct
  
        if (data[IFLA_IPTUN_PROTO])
                parms->proto = nla_get_u8(data[IFLA_IPTUN_PROTO]);
@@ -394,7 +394,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  }
  
  static int ip6_tnl_newlink(struct net *src_net, struct net_device *dev,
-@@ -1666,6 +1874,12 @@ static void ip6_tnl_dellink(struct net_d
+@@ -1676,6 +1884,12 @@ static void ip6_tnl_dellink(struct net_d
  
  static size_t ip6_tnl_get_size(const struct net_device *dev)
  {
@@ -407,7 +407,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return
                /* IFLA_IPTUN_LINK */
                nla_total_size(4) +
-@@ -1683,6 +1897,24 @@ static size_t ip6_tnl_get_size(const str
+@@ -1693,6 +1907,24 @@ static size_t ip6_tnl_get_size(const str
                nla_total_size(4) +
                /* IFLA_IPTUN_PROTO */
                nla_total_size(1) +
@@ -432,7 +432,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
                0;
  }
  
-@@ -1690,6 +1922,9 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -1700,6 +1932,9 @@ static int ip6_tnl_fill_info(struct sk_b
  {
        struct ip6_tnl *tunnel = netdev_priv(dev);
        struct __ip6_tnl_parm *parm = &tunnel->parms;
@@ -442,7 +442,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  
        if (nla_put_u32(skb, IFLA_IPTUN_LINK, parm->link) ||
            nla_put(skb, IFLA_IPTUN_LOCAL, sizeof(struct in6_addr),
-@@ -1700,8 +1935,27 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -1710,8 +1945,27 @@ static int ip6_tnl_fill_info(struct sk_b
            nla_put_u8(skb, IFLA_IPTUN_ENCAP_LIMIT, parm->encap_limit) ||
            nla_put_be32(skb, IFLA_IPTUN_FLOWINFO, parm->flowinfo) ||
            nla_put_u32(skb, IFLA_IPTUN_FLAGS, parm->flags) ||
@@ -471,7 +471,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return 0;
  
  nla_put_failure:
-@@ -1717,6 +1971,7 @@ static const struct nla_policy ip6_tnl_p
+@@ -1727,6 +1981,7 @@ static const struct nla_policy ip6_tnl_p
        [IFLA_IPTUN_FLOWINFO]           = { .type = NLA_U32 },
        [IFLA_IPTUN_FLAGS]              = { .type = NLA_U32 },
        [IFLA_IPTUN_PROTO]              = { .type = NLA_U8 },
index 25dffdc58d5ef9d53ecdf972a04cc73e3aaf579d..7a32e7f8ea57c7f4cd37e150474a3a55991b6797 100644 (file)
@@ -69,7 +69,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4825,6 +4838,9 @@ static struct ata_queued_cmd *ata_qc_new
+@@ -4827,6 +4840,9 @@ static struct ata_queued_cmd *ata_qc_new
                        break;
                }
        }
@@ -79,7 +79,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        return qc;
  }
-@@ -5734,6 +5750,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5736,6 +5752,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -89,7 +89,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5755,6 +5774,12 @@ static void ata_host_release(struct devi
+@@ -5757,6 +5776,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -102,7 +102,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6201,7 +6226,23 @@ int ata_host_register(struct ata_host *h
+@@ -6203,7 +6228,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }