6in4: Corrected tunnelbroker tunnel update URL
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 27 Dec 2015 20:42:26 +0000 (20:42 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 27 Dec 2015 20:42:26 +0000 (20:42 +0000)
Changed the tunnel update URL into format tunnelbrokers
example has, that made it work again. Current method gives "Username/Password
Authentication Failed." when I tried the wget line manually and logread
eventually says also "6in4: update failed". With corrected URL it works fine:
"good 111.222.333.444" or "nochg 111.222.333.444" and logread concurs with
success, and tunnel actually updates.

Tested-by: Vaasa Hacklab <info@vaasa.hacklab.fi>
Signed-off-by: Sami Olmari <sami@olmari.fi>
SVN-Revision: 48006

package/network/ipv6/6in4/Makefile
package/network/ipv6/6in4/files/6in4.sh

index 9eca57af63fd428e1f1a8356f0e8cbf42b6b6360..b51b12d482a3002df14e63866ace1ab276b23448 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=22
+PKG_VERSION:=23
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
index 59747a3783a934595e318191ff167ecdab92eea6..05471db14b6dc2adc67ed4dee60fef817964b6b9 100755 (executable)
@@ -108,7 +108,7 @@ proto_6in4_setup() {
                        fi
                }
 
                        fi
                }
 
-               local url="$http://ipv4.tunnelbroker.net/nic/update?username=$username&password=$password&hostname=$tunnelid"
+               local url="$http://$username:$password@ipv4.tunnelbroker.net/nic/update?hostname=$tunnelid"
                local try=0
                local max=3
 
                local try=0
                local max=3