add safethread
authorJohn Crispin <john@openwrt.org>
Fri, 24 Aug 2012 09:58:42 +0000 (09:58 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 24 Aug 2012 09:58:42 +0000 (09:58 +0000)
SVN-Revision: 33269

package/openssl/Makefile

index d95783aac95d88927e97ac2fae7a331d857c9750..2962c07ed2a617c02d5c0c52ebabd83c6e7cd44b 100644 (file)
@@ -105,7 +105,7 @@ define Build/Configure
        )
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -DOPENSSL_THREADS -pthread -D_REENTRANT -D_THREAD_SAFE -D_THREADSAFE
 
 define Build/Compile
        # XXX: OpenSSL "make depend" will look for installed headers before its own,