ath79: update WA/XC devices UBNT_VERSION to 8.7.4
[openwrt/staging/wigyori.git] / package / network / utils / iproute2 / patches / 170-ip_tiny.patch
index cd687e760104462be127ef9d3787751e0c5e1114..71081c36bccb98d2895fc70b68248b004c33152f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/ip/Makefile
 +++ b/ip/Makefile
-@@ -17,6 +17,13 @@ RTMONOBJ=rtmon.o
+@@ -19,6 +19,13 @@ RTMONOBJ=rtmon.o
  
  include ../config.mk
  
@@ -12,9 +12,9 @@
 +STATIC_SYM_SOURCES:=$(filter-out $(STATIC_SYM_FILTER),$(wildcard *.c))
 +
  ALLOBJ=$(IPOBJ) $(RTMONOBJ)
- SCRIPTS=ifcfg rtpr routel routef
+ SCRIPTS=routel
  TARGETS=ip rtmon
-@@ -46,7 +53,7 @@ else
+@@ -48,7 +55,7 @@ else
  
  ip: static-syms.o
  static-syms.o: static-syms.h
                sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
 --- a/ip/ip.c
 +++ b/ip/ip.c
-@@ -64,11 +64,17 @@ static void usage(void)
+@@ -61,11 +61,17 @@ static void usage(void)
        fprintf(stderr,
                "Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
                "       ip [ -force ] -batch filename\n"
 +#ifndef IPROUTE2_TINY
-               "where  OBJECT := { address | addrlabel | fou | help | ila | ioam | l2tp | link |\n"
-               "                   macsec | maddress | monitor | mptcp | mroute | mrule |\n"
+               "where  OBJECT := { address | addrlabel | amt | fou | help | ila | ioam | l2tp |\n"
+               "                   link | macsec | maddress | monitor | mptcp | mroute | mrule |\n"
                "                   neighbor | neighbour | netconf | netns | nexthop | ntable |\n"
                "                   ntbl | route | rule | sr | tap | tcpmetrics |\n"
                "                   token | tunnel | tuntap | vrf | xfrm }\n"
 +#else
-+              "where  OBJECT := { address | ila | link | macsec | maddress | monitor |\n"
-+              "                   mroute | mrule | neighbor | neighbour | netns | route |\n"
-+              "                   rule | sr | token | tunnel | vrf }\n"
++              "where  OBJECT := { address | link | maddress | monitor |\n"
++              "                   neighbor | neighbour | netns | route |\n"
++              "                   rule | token | tunnel }\n"
 +#endif
                "       OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
                "                    -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
                "                    -f[amily] { inet | inet6 | mpls | bridge | link } |\n"
-@@ -91,37 +97,51 @@ static const struct cmd {
+@@ -88,37 +94,49 @@ static const struct cmd {
        int (*func)(int argc, char **argv);
  } cmds[] = {
        { "address",    do_ipaddr },
@@ -63,9 +63,9 @@
 +#ifndef IPROUTE2_TINY
        { "l2tp",       do_ipl2tp },
        { "fou",        do_ipfou },
-+#endif
        { "ila",        do_ipila },
        { "macsec",     do_ipmacsec },
++#endif
        { "tunnel",     do_iptunnel },
        { "tunl",       do_iptunnel },
 +#ifndef IPROUTE2_TINY
        { "monitor",    do_ipmonitor },
 +#ifndef IPROUTE2_TINY
        { "xfrm",       do_xfrm },
-+#endif
        { "mroute",     do_multiroute },
        { "mrule",      do_multirule },
++#endif
        { "netns",      do_netns },
 +#ifndef IPROUTE2_TINY
        { "netconf",    do_ipnetconf },
-+#endif
        { "vrf",        do_ipvrf},
        { "sr",         do_seg6 },
-+#ifndef IPROUTE2_TINY
        { "nexthop",    do_ipnh },
        { "mptcp",      do_mptcp },
        { "ioam",       do_ioam6 },
 +#endif
        { "help",       do_help },
+       { "stats",      do_ipstats },
        { 0 }
- };
 --- a/lib/Makefile
 +++ b/lib/Makefile
 @@ -3,6 +3,10 @@ include ../config.mk
 +
  UTILOBJ = utils.o utils_math.o rt_names.o ll_map.o ll_types.o ll_proto.o ll_addr.o \
        inet_proto.o namespace.o json_writer.o json_print.o json_print_math.o \
-       names.o color.o bpf_legacy.o bpf_glue.o exec.o fs.o cg_map.o
+       names.o color.o bpf_legacy.o bpf_glue.o exec.o fs.o cg_map.o ppp_proto.o