bcm53xx: add pending patch adding Luxul XWC-2000 DTS file
authorRafał Miłecki <rafal@milecki.pl>
Fri, 4 Oct 2019 08:06:38 +0000 (10:06 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Fri, 4 Oct 2019 08:07:00 +0000 (10:07 +0200)
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/bcm53xx/patches-4.14/130-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch [new file with mode: 0644]
target/linux/bcm53xx/patches-4.14/320-ARM-dts-BCM5301X-Add-serial-to-the-bootargs.patch
target/linux/bcm53xx/patches-4.19/130-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch [new file with mode: 0644]
target/linux/bcm53xx/patches-4.19/320-ARM-dts-BCM5301X-Add-serial-to-the-bootargs.patch

diff --git a/target/linux/bcm53xx/patches-4.14/130-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch b/target/linux/bcm53xx/patches-4.14/130-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch
new file mode 100644 (file)
index 0000000..3320c1e
--- /dev/null
@@ -0,0 +1,80 @@
+From: Dan Haab <dan.haab@legrand.com>
+Date: Wed, 2 Oct 2019 09:57:26 -0600
+Subject: [PATCH] ARM: dts: BCM5301X: Add DT for Luxul XWC-2000
+
+It's a simple network device based on BCM47094 with just a single
+Ethernet port.
+
+Signed-off-by: Dan Haab <dan.haab@legrand.com>
+---
+ arch/arm/boot/dts/Makefile                    |  1 +
+ arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts | 53 +++++++++++++++++++
+ 2 files changed, 54 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -105,6 +105,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+       bcm47094-luxul-abr-4500.dtb \
+       bcm47094-luxul-xap-1610.dtb \
+       bcm47094-luxul-xbr-4500.dtb \
++      bcm47094-luxul-xwc-2000.dtb \
+       bcm47094-luxul-xwr-3100.dtb \
+       bcm47094-luxul-xwr-3150-v1.dtb \
+       bcm47094-netgear-r8500.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
+@@ -0,0 +1,53 @@
++// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
++/*
++ * Copyright 2019 Legrand AV Inc.
++ */
++
++/dts-v1/;
++
++#include "bcm47094.dtsi"
++#include "bcm5301x-nand-cs0-bch8.dtsi"
++
++/ {
++      compatible = "luxul,xwc-2000-v1", "brcm,bcm47094", "brcm,bcm4708";
++      model = "Luxul XWC-2000 V1";
++
++      chosen {
++              bootargs = "earlycon";
++      };
++
++      memory {
++              reg = <0x00000000 0x08000000
++                     0x88000000 0x18000000>;
++      };
++
++      leds {
++              compatible = "gpio-leds";
++
++              status  {
++                      label = "bcm53xx:green:status";
++                      gpios = <&chipcommon 18 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "timer";
++              };
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              restart {
++                      label = "Reset";
++                      linux,code = <KEY_RESTART>;
++                      gpios = <&chipcommon 19 GPIO_ACTIVE_LOW>;
++              };
++      };
++};
++
++&uart1 {
++      status = "okay";
++};
++
++&spi_nor {
++      status = "okay";
++};
index 65f9a52907982d6f9dbb100ffb25e919703056b0..9ce2087c31e0b4606efa2204026dcc42f4dbffb3 100644 (file)
@@ -75,7 +75,7 @@ Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
  
        chosen {
 -              bootargs = "earlycon";
-+              bootargs = "console=ttyS0,115200        earlycon";
++              bootargs = "console=ttyS0,115200 earlycon";
        };
  
        memory {
diff --git a/target/linux/bcm53xx/patches-4.19/130-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch b/target/linux/bcm53xx/patches-4.19/130-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch
new file mode 100644 (file)
index 0000000..beeeda7
--- /dev/null
@@ -0,0 +1,80 @@
+From: Dan Haab <dan.haab@legrand.com>
+Date: Wed, 2 Oct 2019 09:57:26 -0600
+Subject: [PATCH] ARM: dts: BCM5301X: Add DT for Luxul XWC-2000
+
+It's a simple network device based on BCM47094 with just a single
+Ethernet port.
+
+Signed-off-by: Dan Haab <dan.haab@legrand.com>
+---
+ arch/arm/boot/dts/Makefile                    |  1 +
+ arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts | 53 +++++++++++++++++++
+ 2 files changed, 54 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -111,6 +111,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+       bcm47094-luxul-abr-4500.dtb \
+       bcm47094-luxul-xap-1610.dtb \
+       bcm47094-luxul-xbr-4500.dtb \
++      bcm47094-luxul-xwc-2000.dtb \
+       bcm47094-luxul-xwr-3100.dtb \
+       bcm47094-luxul-xwr-3150-v1.dtb \
+       bcm47094-netgear-r8500.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
+@@ -0,0 +1,53 @@
++// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
++/*
++ * Copyright 2019 Legrand AV Inc.
++ */
++
++/dts-v1/;
++
++#include "bcm47094.dtsi"
++#include "bcm5301x-nand-cs0-bch8.dtsi"
++
++/ {
++      compatible = "luxul,xwc-2000-v1", "brcm,bcm47094", "brcm,bcm4708";
++      model = "Luxul XWC-2000 V1";
++
++      chosen {
++              bootargs = "earlycon";
++      };
++
++      memory {
++              reg = <0x00000000 0x08000000
++                     0x88000000 0x18000000>;
++      };
++
++      leds {
++              compatible = "gpio-leds";
++
++              status  {
++                      label = "bcm53xx:green:status";
++                      gpios = <&chipcommon 18 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "timer";
++              };
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              restart {
++                      label = "Reset";
++                      linux,code = <KEY_RESTART>;
++                      gpios = <&chipcommon 19 GPIO_ACTIVE_LOW>;
++              };
++      };
++};
++
++&uart1 {
++      status = "okay";
++};
++
++&spi_nor {
++      status = "okay";
++};
index 65f9a52907982d6f9dbb100ffb25e919703056b0..9ce2087c31e0b4606efa2204026dcc42f4dbffb3 100644 (file)
@@ -75,7 +75,7 @@ Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
  
        chosen {
 -              bootargs = "earlycon";
-+              bootargs = "console=ttyS0,115200        earlycon";
++              bootargs = "console=ttyS0,115200 earlycon";
        };
  
        memory {