modules: Add kmod-w1-slave-ds2413
authorJohn Crispin <john@openwrt.org>
Sat, 17 Jan 2015 13:58:09 +0000 (13:58 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 17 Jan 2015 13:58:09 +0000 (13:58 +0000)
This patch adds support for building the ds2413 one-wire kernel module.

Signed-off-by: Wouter Paesen <wouter@blue-gate.be>
SVN-Revision: 43999

package/kernel/linux/modules/w1.mk

index c2fc6495d46c4187c40b4f4a557449c4d8a4644e..196fe675dc295eab585ccd1adfa799fb43028a54 100644 (file)
@@ -174,3 +174,19 @@ define KernelPackage/w1-slave-ds2760/description
 endef
 
 $(eval $(call KernelPackage,w1-slave-ds2760))
+
+
+define KernelPackage/w1-slave-ds2413
+  TITLE:=DS2413 2 Ch. Addressable Switch
+  KCONFIG:= \
+       CONFIG_W1_SLAVE_DS2413
+  FILES:=$(W1_SLAVES_DIR)/w1_ds2413.ko
+  AUTOLOAD:=$(call AutoProbe,w1_ds2413)
+  $(call AddDepends/w1)
+endef
+
+define KernelPackage/w1-slave-ds2413/description
+ Kernel module for 1-wire DS2413 Dual Channel Addressable Switch support
+endef
+
+$(eval $(call KernelPackage,w1-slave-ds2413))