ath79: add support for TP-Link TL-WR802N V1 and V2
authorLech Perczak <lech.perczak@gmail.com>
Fri, 29 May 2020 18:50:05 +0000 (20:50 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 3 Jun 2020 13:29:37 +0000 (15:29 +0200)
Specification:
- SoC: Qualcomm Atheros QCA9533 (560 MHz, MIPS 24Kc)
- RAM: 32 MiB
- Storage: 4 MiB of Flash on board
- Wireless: Built into QCA9533 (Honey Bee), PHY modes b/g/n
- Ethernet: 1x100M (port0)

Installation through OEM Web Interface:
- Connect to TL-WR802N by Ethernet or Wi-Fi
- Go to web interface:
  [V1] http://192.168.0.1
  [V2] http://192.168.0.254
  Default user is "admin" & password is "admin".
  On V2, there is no DHCP server running by default, so remember to set
  IP manually.
- Go to "System Tools -> Firmware Upgrade"
- Browse for firmware:
  [V1] "*.factory.bin"
  [V2] "*.factory-us.bin" or  "*.factory-eu.bin" for eu model
  Web interface may complain if filename is too long. In such case,
  rename .bin to something shorter.
- Click upgrade

Installation through tftp:
Note: T_OUT, T_IN and GND on the board must be connected to USB TTL
      Serial Configuration 115200 8n1

- Boot the TL-WR802N
- When "Autobooting in 1 seconds" appears type "tpl" followed by enter
- Connect to the board Ethernet port
    (IPADDR: 192.168.1.1, ServerIP: 192.168.1.10)
- tftpboot 0x80000000 <Firmware Image Name>
- Record the result of "printenv bootcmd"
- Enter "erase <Result of 'printenv bootcmd'> +0x3c0000"
    (e.g erase 0x9f020000 +0x3c0000)
- Enter "cp.b 0x80000000 <Result of 'printenv bootcmd'> 0x3c0000"
    (e.g cp.b 0x80000000 0x9f020000 0x3c0000)
- Enter "bootm <Result of 'printenv bootcmd'>"
    (e.g bootm 0x9f020000)

Notes:

When porting from ar71xx target to ath79, I found out that on V2,
reset button is on GPIO12 and active low, instead of GPIO11 and
active high. By cross-flashing V1 firmware to V2, I confirmed
the same is true for V1.
Also according to manual of V1, this one also has green
LED instead of blue - both of those issues were fixed accordingly.

The MAC address assignment has been checked with OEM firmware.

Installation manual based on ar71xx support by Thomas Roberts

Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
[slightly adjust commit message, add MAC address comment]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
(cherry picked from commit 7e513136c63108bf55b38be4d2b65aa00b0d2b26)

target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/uci-defaults/04_led_migration
target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v1.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v2.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9533_tplink_tl-wr802n.dtsi [new file with mode: 0644]
target/linux/ath79/image/tiny-tp-link.mk

index 9b9bc8a7fc15300247bceeb431ab3ae8d3ac47e6..f6efc4d4d658c29459205f29e537066e03870afa 100755 (executable)
@@ -42,6 +42,8 @@ ath79_setup_interfaces()
        tplink,tl-wa901nd-v4|\
        tplink,tl-wa901nd-v5|\
        tplink,tl-wr703n|\
+       tplink,tl-wr802n-v1|\
+       tplink,tl-wr802n-v2|\
        ubnt,bullet-m|\
        ubnt,bullet-m-xw|\
        ubnt,lap-120|\
index 9aa759c6a3f9fac2e60e807f0998503c9766cb18..561aa897f4f01ee05143e1970f188424aa2d9936 100644 (file)
@@ -14,14 +14,16 @@ tplink,archer-c25-v1|\
 tplink,archer-c58-v1|\
 tplink,archer-c59-v1|\
 tplink,archer-c7-v4|\
-tplink,archer-c7-v5)
+tplink,archer-c7-v5|\
+tplink,tl-wr802n-v2)
        migrate_leds "^$boardonly:=tp-link:"
        ;;
 tplink,archer-c7-v2|\
 tplink,tl-wdr3600-v1|\
 tplink,tl-wdr4300-v1|\
 tplink,tl-wdr4300-v1-il|\
-tplink,tl-wdr4310-v1)
+tplink,tl-wdr4310-v1|\
+tplink,tl-wr802n-v1)
        migrate_leds ":blue:=:green:"
        ;;
 wd,mynet-n750)
diff --git a/target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v1.dts b/target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v1.dts
new file mode 100644 (file)
index 0000000..229c5fa
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9533_tplink_tl-wr802n.dtsi"
+
+/ {
+       model = "TP-Link TL-WR802N v1";
+       compatible = "tplink,tl-wr802n-v1", "qca,qca9533";
+};
diff --git a/target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v2.dts b/target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v2.dts
new file mode 100644 (file)
index 0000000..cbfd275
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9533_tplink_tl-wr802n.dtsi"
+
+/ {
+       model = "TP-Link TL-WR802N v2";
+       compatible = "tplink,tl-wr802n-v2", "qca,qca9533";
+};
diff --git a/target/linux/ath79/dts/qca9533_tplink_tl-wr802n.dtsi b/target/linux/ath79/dts/qca9533_tplink_tl-wr802n.dtsi
new file mode 100644 (file)
index 0000000..adf75c7
--- /dev/null
@@ -0,0 +1,98 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca953x.dtsi"
+
+/ {
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-boot = &led_system;
+               led-failsafe = &led_system;
+               led-running = &led_system;
+               led-upgrade = &led_system;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_system: system {
+                       label = "tp-link:green:system";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <50000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x020000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "firmware";
+                               reg = <0x020000 0x3d0000>;
+                               compatible = "tplink,firmware";
+                       };
+
+                       art: partition@3f0000 {
+                               label = "art";
+                               reg = <0x3f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&uboot 0x1fc00>;
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&swphy4>;
+
+       mtd-mac-address = <&uboot 0x1fc00>;
+       mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+       compatible = "syscon", "simple-mfd";
+};
index 2d85143fa3408af5a616cce601a2ec94def544eb..c0909217a1f00ebe75c011c2e218a78dae693220 100644 (file)
@@ -227,6 +227,28 @@ define Device/tplink_tl-wr743nd-v1
 endef
 TARGET_DEVICES += tplink_tl-wr743nd-v1
 
+define Device/tplink_tl-wr802n-v1
+  $(Device/tplink-4mlzma)
+  ATH_SOC := qca9533
+  DEVICE_TITLE := TP-Link TL-WR802N v1
+  TPLINK_HWID := 0x08020001
+  SUPPORTED_DEVICES += tl-wr802n-v1
+endef
+TARGET_DEVICES += tplink_tl-wr802n-v1
+
+define Device/tplink_tl-wr802n-v2
+  $(Device/tplink-4mlzma)
+  ATH_SOC := qca9533
+  DEVICE_TITLE := TP-Link TL-WR802N v2
+  TPLINK_HWID := 0x08020002
+  TPLINK_HWREV := 2
+  SUPPORTED_DEVICES += tl-wr802n-v2
+  IMAGES += factory-us.bin factory-eu.bin
+  IMAGE/factory-us.bin := append-rootfs | mktplinkfw factory -C US
+  IMAGE/factory-eu.bin := append-rootfs | mktplinkfw factory -C EU
+endef
+TARGET_DEVICES += tplink_tl-wr802n-v2
+
 define Device/tplink_tl-wr841-v5
   $(Device/tplink-4m)
   ATH_SOC := ar7240