Let libol-config return paths relative to $(STAGING_DIR).
authorLars-Peter Clausen <lars@metafoo.de>
Wed, 8 Oct 2008 16:40:43 +0000 (16:40 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Wed, 8 Oct 2008 16:40:43 +0000 (16:40 +0000)
SVN-Revision: 12914

libs/libol/Makefile

index f47f66fdf335b7f49faea005c958cbad6760872d..b0a2b30851c32e9c6cc0dc5aa159280001bc0657 100644 (file)
@@ -48,6 +48,9 @@ define Build/InstallDev
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/libol-config \
                $(2)/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/libol-config
 
        $(INSTALL_DIR) $(1)/usr/include/libol
        $(INSTALL_DATA) \