add wrt-radauth package (thanks to Florian Fainelli)
authorNicolas Thill <nico@openwrt.org>
Wed, 19 Oct 2005 11:37:53 +0000 (11:37 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 19 Oct 2005 11:37:53 +0000 (11:37 +0000)
SVN-Revision: 2180

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/wrt-radauth/Config.in [new file with mode: 0644]
openwrt/package/wrt-radauth/Makefile [new file with mode: 0644]
openwrt/package/wrt-radauth/ipkg/wrt-radauth.control [new file with mode: 0644]

index 245ddbb69a423c95043263a28e59f5bb86b54ea6..eeb6d53e53a4b6606119cfa2331f0636e294d023 100644 (file)
@@ -132,6 +132,7 @@ source "package/wificonf/Config.in"
 source "package/wifidog/Config.in"
 source "package/wiviz/Config.in"
 source "package/wondershaper/Config.in"
+source "package/wrt-radauth/Config.in"
 
 comment "Libraries"
 source "package/cgilib/Config.in"
index ab95cab6c5f948ee9d85cfae5a8f304636489aae..4aa9b3a747531f692c7745f52b29a9f7dd6a3385 100644 (file)
@@ -200,6 +200,7 @@ package-$(BR2_PACKAGE_WOL) += wol
 package-$(BR2_PACKAGE_WONDERSHAPER) += wondershaper
 package-$(BR2_PACKAGE_WPA_SUPPLICANT) += wpa_supplicant
 package-$(BR2_PACKAGE_WPUT) += wput
+package-$(BR2_PACKAGE_WRT_RADAUTH) += wrt-radauth
 package-$(BR2_PACKAGE_XINETD) += xinetd
 package-$(BR2_PACKAGE_ZLIB) += zlib
 
diff --git a/openwrt/package/wrt-radauth/Config.in b/openwrt/package/wrt-radauth/Config.in
new file mode 100644 (file)
index 0000000..b21c5fc
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_WRT_RADAUTH
+        tristate "wrt-radauth - a RADIUS MAC authenticator for Broadcom based access points"
+       default m if CONFIG_DEVEL
+       help
+         This software watches the stations associating to a broadcom based
+         AccessPoint (e.g. Linksys WRT54G) and sends an authentication request
+         to the radius-server specified in nvram.
+         
+         http://www.zerfleddert.de/wrt54g/
+         
diff --git a/openwrt/package/wrt-radauth/Makefile b/openwrt/package/wrt-radauth/Makefile
new file mode 100644 (file)
index 0000000..952a4d0
--- /dev/null
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wrt-radauth
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+PKG_MD5SUM:=f941e3139175dc6b87f6c89ba8848a07
+
+PKG_SOURCE_URL:=http://www.zerfleddert.de/wrt54g/
+PKG_SOURCE:=$(PKG_NAME).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(TOPDIR)/package/rules.mk
+
+BR2_PACKAGE_WRT_RADAUTH:=m
+
+$(eval $(call PKG_template,WRT_RADAUTH,wrt-radauth,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               clean all
+       touch $@
+
+$(IPKG_WRT_RADAUTH):
+       install -d -m0755 $(IDIR_WRT_RADAUTH)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/radius-client $(IDIR_WRT_RADAUTH)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/wrt-radauth $(IDIR_WRT_RADAUTH)/usr/sbin/
+       $(RSTRIP) $(IDIR_WRT_RADAUTH)
+       $(IPKG_BUILD) $(IDIR_WRT_RADAUTH) $(PACKAGE_DIR)
diff --git a/openwrt/package/wrt-radauth/ipkg/wrt-radauth.control b/openwrt/package/wrt-radauth/ipkg/wrt-radauth.control
new file mode 100644 (file)
index 0000000..7d2e82c
--- /dev/null
@@ -0,0 +1,6 @@
+Package: wrt-radauth
+Priority: optional
+Section: net
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Florian Fainelli <florian@alphacore.net>
+Source: buildroot internal
+Description: A RADIUS MAC authenticator for Broadcom based access points.