[package] fix urbi compilation failure on octeon (#6987)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 29 Mar 2010 11:03:21 +0000 (11:03 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 29 Mar 2010 11:03:21 +0000 (11:03 +0000)
SVN-Revision: 20574

lang/urbi/Makefile
lang/urbi/patches/005-fix-gcc_4_3-compile.patch

index 4b5c4bec622260ab9cf55b07418e872e4470abe9..945dbf98db0f794c06789edd10f47ad046e962fa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=urbi
 PKG_VERSION:=1.0RC2-l455
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-sdk-$(PKG_VERSION)-src.zip
 PKG_SOURCE_URL:=http://www.gostai.com/downloads/aibo/
index 6fd3b77b47c54543097e18b44f1c9446fb0e9fce..790d73ed76020ad72db4c509fc3481dfa9b72127 100644 (file)
@@ -10,3 +10,13 @@ index bb2546d..38b0d8e 100644
  
  namespace libport
  {
+--- a/src/liburbi/uconversion.cc       2007-01-31 11:37:04.000000000 +0100
++++ b/src/liburbi/uconversion.cc       2010-03-29 09:43:00.000000000 +0200
+@@ -1,5 +1,7 @@
+ #include "urbi/uconversion.hh"
++#include <cstdio>
++
+ #ifndef NO_IMAGE_CONVERSION
+ # include <setjmp.h>