[packages] luaexpat: compile with -fPIC
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 28 Oct 2009 00:28:56 +0000 (00:28 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 28 Oct 2009 00:28:56 +0000 (00:28 +0000)
SVN-Revision: 18194

lang/luaexpat/Makefile

index a0dc1c261288e55edcfc553622e863d7e68bb213..ded0229b9776d1be7d66ccac883a38067cc5415a 100644 (file)
@@ -41,7 +41,7 @@ define Build/Compile
        LUA_LIBDIR="$(STAGING_DIR)/usr/lib/" \
        COMPAT_DIR="$(PKG_BUILD_DIR)/compat-5.1r5" \
        LIB_OPTION="-shared $(TARGET_LDFLAGS)" \
-       CC="$(TARGET_CC) $(TARGET_CFLAGS) -std=c99" \
+       CC="$(TARGET_CC) $(TARGET_CFLAGS) $(FPIC) -std=c99" \
        LD="$(TARGET_CROSS)ld -shared" 
 endef